A script to install Alfresco Community 6.0

Showing results for 
Search instead for 
Did you mean: 

A script to install Alfresco Community 6.0

Active Member
4 9 6,497


Alfresco 6.0 switching to container deployment is a good thing, but Docker has efficiency issues on Mac. What's wrong with a well configured stand-alone Alfresco Community 6.0? Nothing!

Download Three Files

The attached Bash script automates the installation of Alfresco Community 6.0. It looks for 3 downloaded files in the same folder of the script or a folder specified as the script's first parameter.

The above links are for Tomcat 8.5.37, ACS 6.0.7-ga, Search Services 1.3.0.

Run The Install Script

Create an empty folder into which a stand-alone Alfresco Community will be installed. Be sure to set the environment variable JAVA_HOME. Then run the installation script, assuming everything else is in the parent folder:

mkdir 6.0.7-ga
cd 6.0.7-ga

The script will install all three archives, create or modify configuration files and startup scripts, download MySQL JDBC driver and the missing PDF renderer for Mac, start Solr6. It also applies the Share module for alfresco.war, which will ask you to press a few keys in between.

Create Your MySQL Schema

The script creates file tomcat/shared/classes/alfresco-global.properties with these MySQL database settings:

  • Schema name:  alf607ce
  • User name:  alfresco
  • Password:  alfresco

Here are the MySQL commands to create the schema:

$ mysql -u root
create schema alf607ce default character set utf8;
grant all on alf607ce.* to 'alfresco'@'localhost' identified by 'alfresco' with grant option;

Start and Stop Alfresco

./alfresco.sh start
./alfresco.sh jpda start # Start with debug
./alfresco.sh stop

Start and Stop Solr 6

The install script already starts Solr 6 for you. Subsequent start and stop commands are:

search-services/solr/bin/solr start
search-services/solr/bin/solr stop

Other Versions of Alfresco

This install script also works for 6.1.1. There is a bug in 6.1.2-ga that prevents alfresco.war from fully deployed and run in Tomcat. Just don't use it.


Member II

Can this script be run on a Windows 10 machine?

Active Member

This is a bash script, so it should work inside a fully installed Cygwin or MinGW on Windows.

Member II

Tomcat Script Not available. Can someone post a valid link?

Active Member

It is in the "ATTACHMENTS" box right below the last paragraph. It works. I just tried:

Active Member

Hi , I want to run the script in ubuntu 18.04 but there are a mistake I don't Know how to solve it.

Active Member

Ubuntu sed command doesn't like -i ""
The only way I can make the script work for both Mac and Ubuntu is for sed to create backup files.

sed -i.bak -e 's|connectionTimeout=|URIEncoding="UTF-8" connectionTimeout=|' server.xml
sed -i.bak -e 's|shared.loader=|shared.loader=${catalina.base}/shared/classes|' catalina.properties

Member II

Hi Michael, thank you for this great script ! I ran it  , on Ubuntu 16.04 and everything loads (well almost)

I can get to tomcat control panel

I can get to the Solr Admin panel

I can start and stop and alfresco from the command prompt

the only thing I cannot load is Alfresco - what config files should I look at to troubleshoot this , thank you 

Member II

Hi @pfb6736 

I don't hav emuch experience on Alfresco, still am trying to make it work, probably I can help little bit here, make sure your tomcat is listening on 8080, and in alfresco-global.properites you can check. 

netstat -an | grep 8080, also check in catalina.out file, whether the server is started, if yes then your GUI will work. 

And if you are using nginx with port redirection, then wihtout 8080 it will work. 

Member II

I tried this script in CentOS 7, following are the steps taken,

  1. Tomcat doesn't work from this link, downloaded from this link
  2. Other 2 files and install script downloaded from this site
  3. Set JAVA_HOME environment path
  4. Installed MySQL (MariaDB) and created the schema and user as suggested in this site

Post this, I executed the install script and when i see tomcat doesn't start, alfresco doesn't get started. 

When I check in catalina.out file I see,

01-Nov-2019 04:07:33.119 SEVERE [main] org.apache.catalina.startup.Catalina.start Cannot start server. Server instance is not configured.

I came to this site because 5.2 community edition am not able to handle docx format more than 1MB and xlsx and xls file landscape orientation doesn't work as expected. 

Any help would be appreciated.