Demo Tomcat Packages for Alfresco 3.4

cancel
Showing results for 
Search instead for 
Did you mean: 

Demo Tomcat Packages for Alfresco 3.4

wabson
Active Member II
0 7 268
Downloads and more information can now be found on the dedicated Tomcat Bundles page.



The eagle-eyed amongst you will have noticed that starting with Alfresco 3.4 a number of changes have been made to the way in which Alfresco binaries are packaged for distribution.



The new Bitrock installer makes installing the server much less challenging for new users and offers more control for power users. Also welcome should be the general tidying up that has gone on, with most packages now standardised as ZIP files, hopefully ending the which-file-should-I-download confusion.



The only casualty has been the Tomcat bundle packages, which are no longer shipped due to the overhead in maintaining these separately from the Bitrock stack and WAR bundles.



Now while they're both great for experimental users and system admins respectively, it doesn't beat the sheer speed of unzipping a ZIP file and double-clicking alf_start.bat, the method I've always used to quickly spin up demo or test instances on my Windows system. So, I packaged up my own unofficial Tomcat demo bundle for 3.4.



From 3.4.b I've added a Linux bundle based on the same components, but with my own alfresco.sh script that can be used to stop and start the server. It should work exactly the same as the old Alfresco Tomcat .tar.gz bundles, but with a dedicated MySQL also included.



Downloads and more information can now be found on the dedicated Tomcat Bundles page.
7 Comments
blog_commenter
Active Member
Hey Will,



I've done a similar thing. basically took the latest available tomcat bundle, ripped out anything alfresco that come with the new zip distrib. zipped that out as a 'barebones package'. after that, through symlinks and bash tricks, i can very easily extract any new zip distribution on top of a copy of that barebones package, replicating the needed speed of install.



Cheers,

Romain
blog_commenter
Active Member
Hi!

Excellent help I was going in quite the same direction and this shortcut really helped me. For other users just little advice if Alfresco doesn't start.

Check your alfreso.bat file and test your java start options, especially memory configuration. I'm using -Xmx896m -Xss896k instead of -Xmx1024m -Xss1024k and it works great.

thnx

Janez
wabson
Active Member II
Hi Janez, yes, there is lots of scope to fine tune the memory settings for your system, either giving it more if you have plenty spare or less if you do not. There is more information on the wiki - http://wiki.alfresco.com/wiki/JVM_Tuning
blog_commenter
Active Member
Hi Will -



A very basic question.... how do you install the 3.4 edition if you don't have GUI on your server. I have a Ubuntu server without a GUI, the installation instructions appear to be for GUI only. Thanks.
wabson
Active Member II
Hi Golash, the instructions are for creating the Tomcat bundle package, rather than installing on your server. You could use the this package to install Alfresco on your server (just unzip it), but you'd be better using the native Tomcat package on your platform. The WAR file bundle has all the bits you'll need to do this, see the docs for more info.
blog_commenter
Active Member
Why Apache Tomcat 6.0.18? The current version is already 6.0.29 and 6.0.18 was released more than *two years ago*: http://tomcat.apache.org/tomcat-6.0-doc/changelog.html
wabson
Active Member II
Andreas, 6.0.18 is the version that our QA team test against, so is likely to be more reliable than newer versions. You're welcome to try others at your own risk, but the older version does seem to be more stable for me from the comparisons I've done.