A guide on Installing and configuring non-docker 201901GA (or any 6.x) ?

cancel
Showing results for 
Search instead for 
Did you mean: 
wclemo
Active Member

A guide on Installing and configuring non-docker 201901GA (or any 6.x) ?

Jump to solution

I am looking for help on installing and configuring the ver 6.x ACS community edition manually. I don't want to use docker. I want to install manually via the distribution zip. All my installations attempts for various v6x versions have been unsuccessful, usually with Alfresco failing to start up successfully. I noticed that there are several setup guides on the net for previous versions but one can hardly get version 6 ones (I wonder how the uptake of ver 6 is !!). The only manual install guide I found is the script https://community.alfresco.com/community/ecm/blog/2019/02/05/a-script-to-install-alfresco-community-...  but somehow it didn't work for me. I also followed the official Alfresco guide but despite several days attempts I didn't succeed.

I must mention that java, tomcat and various apps that Alfresco uses are not my sphere. Just out of curiosity I tried the docker install and it worked "out of the box", but as I mentioned I dont want to do docker. For those who have managed to do a successful manual install, would you care to kindly share your step by step notes ?

Thanks in advance

Clemo

1 Solution

Accepted Solutions

Re: A guide on Installing and configuring non-docker 201901GA (or any 6.x) ?

Jump to solution

Also this guide can help you, it's still valid for Alfresco 6:

http://beecon.buzz/2017/assets/files/EF09/EF09-Installing-Alfresco-components-1-by-1.pdf 

Software Engineer in Alfresco Search Team.

View solution in original post

9 Replies

Re: A guide on Installing and configuring non-docker 201901GA (or any 6.x) ?

Jump to solution

Did you try this one?


https://docs.alfresco.com/community/concepts/install-community-intro.html

Software Engineer in Alfresco Search Team.
wclemo
Active Member

Re: A guide on Installing and configuring non-docker 201901GA (or any 6.x) ?

Jump to solution

I did try several times that but somehow could not make it work for me. It was failing during startup. Probably someone more experienced would make it work.

Re: A guide on Installing and configuring non-docker 201901GA (or any 6.x) ?

Jump to solution

Also this guide can help you, it's still valid for Alfresco 6:

http://beecon.buzz/2017/assets/files/EF09/EF09-Installing-Alfresco-components-1-by-1.pdf 

Software Engineer in Alfresco Search Team.

View solution in original post

wclemo
Active Member

Re: A guide on Installing and configuring non-docker 201901GA (or any 6.x) ?

Jump to solution

Thanks for this link. This is very helpful and I am already trying it out and the results seem to be very encouraging so far.

cesarista
Advanced

Re: A guide on Installing and configuring non-docker 201901GA (or any 6.x) ?

Jump to solution

Hi:

An alternate installer may be this one --> GitHub - loftuxab/alfresco-ubuntu-install: Alfresco script based install for Ubuntu 

Kind regards.

--C.

wclemo
Active Member

Re: A guide on Installing and configuring non-docker 201901GA (or any 6.x) ?

Jump to solution

Hi Capillas,

Thanks so much for this reference. Actually this is all I need. Everything is well scripted and documented withing the script. I only need to customize it slightly to my needs. (By the way the Github page says its updated to v6.0.7 but its actually 6.1.1...much better ! )

Regards,

Clemo

dadyodoo
Member II

Re: A guide on Installing and configuring non-docker 201901GA (or any 6.x) ?

Jump to solution

Hello, if you managed to install alfresco 6.1 with the zip distribution, please share it with us because I could not do it after several attempts.

wclemo
Active Member

Re: A guide on Installing and configuring non-docker 201901GA (or any 6.x) ?

Jump to solution

Hi,

I finally managed to successfully install Alfresco 6 using the distribution zip. This particular script https://community.alfresco.com/external-link.jspa?url=https%3A%2F%2Fgithub.com%2Floftuxab%2Falfresco...  referred to me by Cesar Capillas pretty much does almost everything to make for a successful install.

I tweaked few links to get what I wanted. For example I preferred using MariaDB and I had to modify the script to use it. I  used Tomcat 8.5 instead of the 8.0 in the script. I made sure to stick with Java 8. My previous experiences with higher versions of these two (Tomcat 9 and Java 11) were unsuccessful and that's the reason I preferred to stick with lower versions.

It is worthy to note that the script is based on Alfresco version 6.1.1. This is what I started with, and once that worked, I then tried with the latest v6.1.2. Since the source links of the script do not have Alfresco v6.1.2, I had to download the distribution zip from Alfresco download site. After copying the the necessary war, amp and jar files to a folder from the extracted distribution zip I then modified the script to pull those files from there.

Alfresco 6.1.2 uses ActiveMQ for messaging. When testing the installation I initially disabled it use by adding the entry

messaging.subsystem.autoStart=false to the global properties file. When I confirmed the setup was working I then installed ActiveMQ and configured as necessary and it worked.

I was testing with Debian 9 "stretch" and I noticed from the catalina.out log file that ImageMagick was not loading, but when I then reinstalled it manually it got loaded. During debug I realised that the script's imagemagick entry was trying to install among other libraries libpng3. This apparently is not available in Debian repos and was causing the script to skip imagemagick installation. I disabled the libpng3 from the script.

Am so relieved that v6 distribution install finally worked as like you I had previously tried several times and I was just about to give up before getting useful links here. I am not familiar at all in Tomcat and/or related fields but I can assist you where possible to have your setup working.

Clemo

joseantonionava
Established Member

Re: A guide on Installing and configuring non-docker 201901GA (or any 6.x) ?

Jump to solution

Get done at first time.

Thank you.