AAAR data does not increase

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Member II

AAAR data does not increase

Hello

I am conducting the AAAR extraction process. The variables alfrescoAuditLimit and alfrescoNodeLimit are set to the value 50000. When executing the extraction, the 50000 actions are inserted, however when running the second time the data is not incremented. The same data was imported.

In the documentation you are informed that the limit is 100000 per hour.

Is there any configuration for the data to be incremented?

3 Replies
Highlighted
Alfresco Employee

Re: AAAR data does not increase

Hi Alex,

Usually when this happen is because there is an error in the import job and the batch is not able to correctly get the audit trail in the warehouse.

This could be the reason why at the second run, the extraction get the same data: each time the job checks the extracted data from the warehouse to define what has to be extracted more.

I recommend you to check the Pentaho catalina.out, if you have any error.

I hope this help.

Highlighted
Member II

Re:  AAAR data does not increase

I am sending the process logs.

Since the creation of the AAAR bank, the first execution and the second execution after 1 hour.

I could not identify the reason for not increasing.

Would you help me?

I am also sending my configuration file.

log.tar.gz

Highlighted
Alfresco Employee

Re: AAAR data does not increase

Hi Alex,

The log says:

09:40:15,913 ERROR [ConnectionServiceImpl] ConnectionServiceImpl.ERROR_0004 - Unable to add connection name : connection name was AAAR_DataMart caused by null
2017/12/04 09:40:15 - Abort.0 - ERROR (version 7.0.0.0-25, build 1 from 2016-11-05 15.35.36 by buildguy) : Row nr 1 causing abort : [null], [{"changed":true,"connectSql":"","databaseName":"AAAR_DataMart","databasePort":"3306","hostname":"localhost","name":"AAAR_DataMart","password":"...","username":"root","attributes":{},"connectionPoolingProperties":{},"extraOptions":{},"accessType":"NATIVE","databaseType":{"defaultDatabasePort":"3306","extraOptionsHelpUrl":"http://dev.mysql.com/doc/refman/5.0/en/connector-j-reference-configuration-properties.html","name":"MySQL","shortName":"MYSQL","supportedAccessTypes":["NATIVE","ODBC","JNDI"]}}], [409]
2017/12/04 09:40:15 - Abort.0 - ERROR (version 7.0.0.0-25, build 1 from 2016-11-05 15.35.36 by buildguy) : Aborting after having seen 1 rows.


For some reasons the datasource name cannot be added.

The extraction fails because the AAAR is not correctly installed.

You can manually add the data source, if you want.

I hope this will help.