AAAR v4.5 Installation Issue

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Active Member II

AAAR v4.5 Installation Issue

Jump to solution

Hi @Francesco Corti,

Unable to use AAAR with Alfresco, am unable to extract anything from the Alfresco.

I don't see any error in any of the logs. 

I couldn't figure out what and where things are not in place.

Kindly help me out.

______________________________________________________________________________________________

Environment Details:

Windows 7

Alfresco CE 201701GA / 5.2

AAAR 4.5

Pentaho DI 7

Pentaho BA 7

_______________________________________________________________________________________________

AAAR Config:

<AAAR>
<parameter name="AAARGetAudit" value="true"></parameter>
<parameter name="AAARGetNodes" value="true"></parameter>
<parameter name="AAARGetWorkflows" value="true"></parameter>
<parameter name="alfrescoAuditLimit" value="50000"></parameter>
<parameter name="alfrescoNodeLimit" value="50000"></parameter>
<parameter name="alfrescoFtpPath" value="alfresco"></parameter>
<parameter name="alfrescoFtpPort" value="121"></parameter>
<parameter name="alfrescoHost" value="172.16.13.104"></parameter>
<parameter name="alfrescoLogin" value="admin"></parameter>
<parameter name="alfrescoPassword" value="admin"></parameter>
<parameter name="alfrescoProtocol" value="http"></parameter>
<parameter name="alfrescoPort" value="8080"></parameter>
<parameter name="alfrescoType" value="Alfresco_5_2"></parameter>
<parameter name="databaseBin" value="/usr/bin"></parameter>
<parameter name="databaseType" value="PostgreSql"></parameter>
<parameter name="databaseHost" value="localhost"></parameter>
<parameter name="databaseLogin" value="postgres"></parameter>
<parameter name="databasePassword" value="postgres"></parameter>
<parameter name="databasePort" value="5432"></parameter>
<parameter name="databaseSchemaAAAR" value="AAAR_DataMart"></parameter>
<parameter name="databaseSchemaKettle" value="AAAR_Kettle"></parameter>
<parameter name="databaseSchemaMain" value="postgres"></parameter>
<parameter name="kettlePath" value="D:\Phani Share\pdi-ce-7.1.0.0-12\data-integration"></parameter>
<parameter name="kettleVersion" value="7"></parameter>
<parameter name="pentahoAAARPath" value="/public/AAAR"></parameter>
</AAAR>

_______________________________________________________________________________________________

Ending up with warning while installing:

_______________________________________________________________________________________________

Dashboard always seems to be empty even after installing:

1 Solution

Accepted Solutions
Highlighted
Active Member II

Re: AAAR v4.5 Installation Issue

Jump to solution

Running AAAR_Extract.bat from terminal helped!

Thank you so much Franc.

View solution in original post

4 Replies
Highlighted
Alfresco Employee

Re: AAAR v4.5 Installation Issue

Jump to solution

Hi Anandhan,

Did you extract data using the AAAR_Extract batch?

A.A.A.R. - Extract from Alfresco using Pentaho by F.Corti 

Cheers.

Highlighted
Active Member II

Re: AAAR v4.5 Installation Issue

Jump to solution

Yes, I did, but nothing seems to happen.

It is closing immediately and there is no log even. 

Highlighted
Alfresco Employee

Re: AAAR v4.5 Installation Issue

Jump to solution

What do you mean with "it is closing", if it is a batch to launch from a terminal?

Highlighted
Active Member II

Re: AAAR v4.5 Installation Issue

Jump to solution

Running AAAR_Extract.bat from terminal helped!

Thank you so much Franc.

View solution in original post