acs-community-deployment, Docker(compose) and Windows 10

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
hans_vd_zwet
Member II

acs-community-deployment, Docker(compose) and Windows 10

Hello people,

I'm currently in the proces of determining if Alfresco 6 will be a good fit for a (Web) solution we are going to build. 

One of the nice things about this new project we're about to start is that we will be using docker as a development platform.

I've downloaded and started the acs-community-download sources from github on both my (linux)laptop and my (windows 10 pro)desktop.

On my linux laptop there is no problem whatsoever, but on my windows 10  desktop things appear to start up properly, but as soon as I want to access Share there is a lot of disk-activity, an orange screen but never a login dialog ... From there on things seem to  hang and they won't even shut down gracefully as the command shell is not responding anymore.

Now my question, 

Is this a known problem ?  ... and if so, is there a solution ?

thnx in advance for any help/guidance that can be provided.

Hans.

4 Replies
angelborroy
Expert

Re: acs-community-deployment, Docker(compose) and Windows 10

When you use Docker Compose as base, the problem is not in Alfresco but in Docker. Probably your Docker is not properly installed on Windows or there is some permissions problem on it.

Software Engineer in Alfresco Search Team.
hans_vd_zwet
Member II

Re: acs-community-deployment, Docker(compose) and Windows 10

Dunno about the 'not properly installed' as everything else works so far (PostgreSQL, MySQL, RabbitMQ, MongoDB, Spring Boot, just to name a few). No specific permissions where mentioned as far as I know (although that seems to make sense) ... Anything in particular I should be looking for here ?

angelborroy
Expert

Re: acs-community-deployment, Docker(compose) and Windows 10

You can start inspecting the log files...

Software Engineer in Alfresco Search Team.
hans_vd_zwet
Member II

Re: acs-community-deployment, Docker(compose) and Windows 10

Unfortunately, that's where part of the problem sits/is .... My complete docker locks up ... so it's kinda hard to get to the logs.