Alfresco 4.2.4 Clustering

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
mfaquih
Active Member

Alfresco 4.2.4 Clustering

I am using alfresco version 4.2.4 (single node). Now I want to setup up a cluster of two nodes using alfresco clustering facility. 

I am looking for a detail document which should illustrate step by step instruction that I can follow on how to create alfresco cluster (two nodes only). 

6 Replies
afaust
Master

Re: Alfresco 4.2.4 Clustering

mfaquih
Active Member

Re: Alfresco 4.2.4 Clustering

Thanks, I am using alfresco version 4.2.4, the link that you shared is for version 4.2.7, just wondering both releases do not have any significant changes. I can use 4.2.7 documentation to setup cluster on for version 4.2.4 ? 

afaust
Master

Re: Alfresco 4.2.4 Clustering

Based on the documented product support policy, 4.2.7 is functionally identical to 4.2.4. Both are service pack releases of the 4.2 version line.

mfaquih
Active Member

Re: Alfresco 4.2.4 Clustering

I am using alfresco version-4.2.4, I am unable to locate 'ehcache-custom.xml.sample.cluster' file on my machine. Can you please suggest from where I can get this file. 

Also I have an alfresco server that is on version 4.1.10, there I can locate 'ehcache-custom.xml.sample.cluster' file on path: "alfresco-4.1.10/tomcat/shared/classes/alfresco/extension". Can I use the same file for alfresco version- 4.2.4.

afaust
Master

Re: Alfresco 4.2.4 Clustering

Alfresco 4.2 does not use ehcache for clustering so there is no ehcache-custom.xml.sample.cluster file to be found. ehcache has been replaced with Hazelcast for clustering in Alfresco Enterprise 4.2. You typically do not need to make any changes to the default Hazelcast configuration. All caches are now defined via the caches.properties file and can be overriden via the alfresco-global.properties file.

mfaquih
Active Member

Re: Alfresco 4.2.4 Clustering

We are using 'lucene' search subsystem on alfresco-4.2.4, will this cause any issue on Alfresco cluster because as per the alfresco document (below link) setting up repository server cluster should have SOLR indexes.

http://docs.alfresco.com/4.2/tasks/cluster-setup.html


Can you please suggest if setting alfresco cluster using 'lucene' indexing will not cause any issue ?