alfresco 5.2 can't preview docx

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Member II

alfresco 5.2 can't preview docx

Hi

I have installed Alfresco Community 5.2 on ubuntu 17.10.1 Installation Type: Easy. It can't preview File docx and doc but It can preview xlsx, pdf file

file catalina.out and alfresco-global.properties in attach

Could you please help.

1 Reply
Highlighted
Professional

Re: alfresco 5.2 can't preview docx

Sorry your post never got a reply. I hope you eventually got this to work.

You might want to pay attention to the Supported Stacks: Supported Platforms | Alfresco Documentation 

For example, you are running 5.2 which Alfresco supports on Ubuntu 16.04. That does not mean it absolutely will not work on 17.10.1 but it certainly adds risk.

Similarly, that same page says that it supports LibreOffice 5.2.1.2. According to your alfresco-global.properties file you are using the version of LibreOffice shipped with Alfresco so that probably matches.

Did you install all of the prerequisite Ubuntu packages such as ttf-mscorefonts-installer fonts-noto fontconfig libcups2 libfontconfig1 libglu1-mesa libice6 libsm6?

The log indicates that it cannot find a supported transformer for DOCX files. Did you do any customizations or configurations with regard to transformer mimetypes?