Alfresco 6.1 doesn't start anymore after power failure

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Active Member II

Alfresco 6.1 doesn't start anymore after power failure

Jump to solution

Hello,

I have installed last year Alfresco 6.1 on a Linux server running debian/testing.

Tomcat : 9.0.27

Java : openJDK 11.0.6

PostgreSQL : 11.6.2

This server ran like expected until a power supply failure. I have swapped this power supply and this server restarted without any error (no disc corruption for example).

Apache runs fine, tomcat, solr, activemq also. But share and alfresco refuse to start !

More precisely, catalina.out contains :

[2020-02-01 14:59:06] [info] Déploiement du descripteur de configuration [/etc/tomcat9/Catalina/localhost/share.xml]
[2020-02-01 14:59:07] [info] Au moins un fichier JAR a été analysé pour trouver des TLDs mais il n'en contenait pas, le mode "debug" du journal peut être activé pour obtenir une liste complète de JAR scannés sans succès; éviter d'analyser des JARs inutilement peut améliorer sensiblement le temps de démarrage et le temps de compilation des JSPs
[2020-02-01 14:59:07] [info] Le traitement du descripteur de déploiement [/etc/tomcat9/Catalina/localhost/share.xml] a pris [894] ms

If I purge /opt/alfresco, I have seen that share and alfresco are never deployed !

Of course, I have tried to switch default log to debug without any result.

How can I fix this trouble ?

Best regards,

JKB

1 Solution

Accepted Solutions
Highlighted
Active Member II

Re: Alfresco 6.1 doesn't start anymore after power failure

Jump to solution

It was a tomcat 9 configuration issue.

[Service]

# Configuration
Environment="CATALINA_HOME=/usr/share/tomcat9"
#Environment="CATALINA_BASE=/var/lib/tomcat9"
Environment="CATALINA_BASE=/opt/alfresco"
Environment="CATALINA_TMPDIR=/tmp"
Environment="JAVA_OPTS=-Djava.awt.headless=true"

But I'm sure I haven't modified systemd configuration...

Best regards,

JB

View solution in original post

7 Replies
Highlighted
Moderator
Moderator

Re: Alfresco 6.1 doesn't start anymore after power failure

Jump to solution

What is the setup on your current environment ? Is it via docker or its a manual setup ?

Can you attach logs here including catalina.out, share.log, alfresco.log ?

~Abhinav
(ACSCE, AWS SAA-C02, GAIQ)
Highlighted
Active Member II

Re: Alfresco 6.1 doesn't start anymore after power failure

Jump to solution

It's a manual setup. share.log and alfresco.log are both empty.

Catalina.out:

[2020-02-02 22:58:42] [info] Version du serveur:        Apache Tomcat/9.0.27 (Debian)
[2020-02-02 22:58:42] [info] Serveur compilé:       Oct 14 2019 09:31:50 UTC
[2020-02-02 22:58:42] [info] Version du serveur:      9.0.27.0
[2020-02-02 22:58:42] [info] Nom de l'OS:           Linux
[2020-02-02 22:58:42] [info] Version de l'OS:        5.3.0-2-amd64
[2020-02-02 22:58:42] [info] Architecture:          amd64
[2020-02-02 22:58:42] [info] Répertoire de Java:     /usr/lib/jvm/java-11-openjdk-amd64
[2020-02-02 22:58:42] [info] Version de la JVM:           11.0.6+10-post-Debian-1
[2020-02-02 22:58:42] [info] Fournisseur de la JVM:            Debian
[2020-02-02 22:58:42] [info] CATALINA_BASE:         /var/lib/tomcat9
[2020-02-02 22:58:42] [info] CATALINA_HOME:         /usr/share/tomcat9
[2020-02-02 22:58:42] [info] Argument de la ligne de commande: --add-opens=java.base/java.lang=ALL-UNNAMED
[2020-02-02 22:58:42] [info] Argument de la ligne de commande: --add-opens=java.base/java.io=ALL-UNNAMED
[2020-02-02 22:58:42] [info] Argument de la ligne de commande: --add-opens=java.rmi/sun.rmi.transport=ALL-UNNAMED
[2020-02-02 22:58:42] [info] Argument de la ligne de commande: -Djava.util.logging.config.file=/var/lib/tomcat9/conf/logging.properties
[2020-02-02 22:58:42] [info] Argument de la ligne de commande: -Djava.util.logging.manager=org.apache.juli.ClassLoaderLogManager
[2020-02-02 22:58:42] [info] Argument de la ligne de commande: -Djava.awt.headless=true
[2020-02-02 22:58:42] [info] Argument de la ligne de commande: -Djdk.tls.ephemeralDHKeySize=2048
[2020-02-02 22:58:42] [info] Argument de la ligne de commande: -Djava.protocol.handler.pkgs=org.apache.catalina.webresources
[2020-02-02 22:58:42] [info] Argument de la ligne de commande: -Dorg.apache.catalina.security.SecurityListener.UMASK=0027
[2020-02-02 22:58:42] [info] Argument de la ligne de commande: -Dignore.endorsed.dirs=
[2020-02-02 22:58:42] [info] Argument de la ligne de commande: -Dcatalina.base=/var/lib/tomcat9
[2020-02-02 22:58:42] [info] Argument de la ligne de commande: -Dcatalina.home=/usr/share/tomcat9
[2020-02-02 22:58:42] [info] Argument de la ligne de commande: -Djava.io.tmpdir=/tmp
[2020-02-02 22:58:42] [info] Chargement de la librairie Apache Tomcat Native [1.2.23] en utilisant APR version [1.6.5]
[2020-02-02 22:58:42] [info] Fonctionnalités d'APR: IPv6 [true], sendfile [true], accept filters [false], random [true]
[2020-02-02 22:58:42] [info] Configuration de APR/OpenSSL: useAprConnector [false], useOpenSSL [true]
[2020-02-02 22:58:42] [info] OpenSSL a été initialisé avec succès [OpenSSL 1.1.1d  10 Sep 2019]
[2020-02-02 22:58:42] [info] Initialisation du gestionnaire de protocole ["http-nio-8080"]
[2020-02-02 22:58:42] [info] Initialisation du gestionnaire de protocole ["ajp-nio-8009"]
[2020-02-02 22:58:42] [info] L'initialisation du serveur a pris [1 502] millisecondes
[2020-02-02 22:58:42] [info] Démarrage du service [Catalina]
[2020-02-02 22:58:42] [info] Démarrage du moteur de Servlets: [Apache Tomcat/9.0.27 (Debian)]
[2020-02-02 22:58:42] [info] Déploiement du descripteur de configuration [/etc/tomcat9/Catalina/localhost/share.xml]
[2020-02-02 22:58:44] [info] Au moins un fichier JAR a été analysé pour trouver des TLDs mais il n'en contenait pas, le mode "debug" du journal peut être activé pour obtenir une liste complète de JAR scannés sans succès; éviter d'analyser des JARs inutilement peut améliorer sensiblement le temps de démarrage et le temps de compilation des JSPs
[2020-02-02 22:58:44] [warning] La création de l'instance de SecureRandom pour le générateur d'id de session en utilisant [SHA1PRNG] a pris [206] millisecondes
[2020-02-02 22:58:44] [info] Le traitement du descripteur de déploiement [/etc/tomcat9/Catalina/localhost/share.xml] a pris [1 883] ms
[2020-02-02 22:58:44] [info] Déploiement du descripteur de configuration [/etc/tomcat9/Catalina/localhost/manager.xml]
[2020-02-02 22:58:44] [warning] L'attribut path avec la valeur [/manager] dans le descripteur de déploiement [/etc/tomcat9/Catalina/localhost/manager.xml] a été ignoré
[2020-02-02 22:58:45] [info] Au moins un fichier JAR a été analysé pour trouver des TLDs mais il n'en contenait pas, le mode "debug" du journal peut être activé pour obtenir une liste complète de JAR scannés sans succès; éviter d'analyser des JARs inutilement peut améliorer sensiblement le temps de démarrage et le temps de compilation des JSPs
[2020-02-02 22:58:45] [info] Le traitement du descripteur de déploiement [/etc/tomcat9/Catalina/localhost/manager.xml] a pris [433] ms
[2020-02-02 22:58:45] [info] Déploiement du descripteur de configuration [/etc/tomcat9/Catalina/localhost/alfresco.xml]
[2020-02-02 22:58:45] [info] Au moins un fichier JAR a été analysé pour trouver des TLDs mais il n'en contenait pas, le mode "debug" du journal peut être activé pour obtenir une liste complète de JAR scannés sans succès; éviter d'analyser des JARs inutilement peut améliorer sensiblement le temps de démarrage et le temps de compilation des JSPs
[2020-02-02 22:58:45] [info] Le traitement du descripteur de déploiement [/etc/tomcat9/Catalina/localhost/alfresco.xml] a pris [429] ms
[2020-02-02 22:58:45] [info] Déploiement du descripteur de configuration [/etc/tomcat9/Catalina/localhost/solr.xml]
[2020-02-02 22:58:45] [warning] L'attribut path avec la valeur [/solr] dans le descripteur de déploiement [/etc/tomcat9/Catalina/localhost/solr.xml] a été ignoré
Highlighted
Moderator
Moderator

Re: Alfresco 6.1 doesn't start anymore after power failure

Jump to solution

Have you installed both alfresco.war and share.war files in same tomcat ? I don't see alfresco or share application startup correctly by looking at the logs. There are no logs pertaining to startup of these two applications. It is hard to tell what could have caused the failure at this moment.

~Abhinav
(ACSCE, AWS SAA-C02, GAIQ)
Highlighted
Senior Member

Re: Alfresco 6.1 doesn't start anymore after power failure

Jump to solution

Are you sure you checked the right catalina.out?

What do you mean by


@jkb wrote:

If I purge /opt/alfresco, I have seen that share and alfresco are never deployed !


By good old deployment convention /opt/alfresco is the root to store application and data.

Highlighted
Active Member II

Re: Alfresco 6.1 doesn't start anymore after power failure

Jump to solution

Yes, I have.

Root rayleigh:[/opt/alfresco] > find . -name "alfresco.war"
./webapps/alfresco.war
Root rayleigh:[/opt/alfresco] > find . -name "share.war"
./webapps/share.war

And /etc/tomcat9/Catalina/localhost contains alfresco.xml and share.xml.

My server only launches tomcat 9.

Highlighted
Active Member II

Re: Alfresco 6.1 doesn't start anymore after power failure

Jump to solution

I'm sure I have posted the right catalina.out.

Maybe tomcat9.service (from systemd) has changed. It contains :

#
# Systemd unit file for Apache Tomcat
#

[Unit]
Description=Apache Tomcat 9 Web Application Server
Documentation=https://tomcat.apache.org/tomcat-9.0-doc/index.html
After=network.target

[Service]

# Configuration
Environment="CATALINA_HOME=/usr/share/tomcat9"
Environment="CATALINA_BASE=/var/lib/tomcat9"
Environment="CATALINA_TMPDIR=/tmp"
Environment="JAVA_OPTS=-Djava.awt.headless=true"

# Lifecycle
Type=simple
ExecStartPre=+/usr/libexec/tomcat9/tomcat-update-policy.sh
ExecStart=/bin/sh /usr/libexec/tomcat9/tomcat-start.sh
SuccessExitStatus=143
Restart=on-abort

# Logging
SyslogIdentifier=tomcat9

# Security
User=tomcat
Group=tomcat
PrivateTmp=yes
AmbientCapabilities=CAP_NET_BIND_SERVICE
NoNewPrivileges=true
CacheDirectory=tomcat9
CacheDirectoryMode=750
ProtectSystem=strict
ReadWritePaths=/etc/tomcat9/Catalina/
ReadWritePaths=/var/lib/tomcat9/webapps/
ReadWritePaths=/var/log/tomcat9/
ReadWritePaths=/opt/alfresco
ReadWritePaths=/opt/alfresco-data
RequiresMountsFor=/var/log/tomcat9 /var/lib/tomcat9

[Install]
WantedBy=multi-user.target

If I remember, I have modified ReadWritePaths directives to start alfresco in /opt/alfresco.

Regards,

JB

Highlighted
Active Member II

Re: Alfresco 6.1 doesn't start anymore after power failure

Jump to solution

It was a tomcat 9 configuration issue.

[Service]

# Configuration
Environment="CATALINA_HOME=/usr/share/tomcat9"
#Environment="CATALINA_BASE=/var/lib/tomcat9"
Environment="CATALINA_BASE=/opt/alfresco"
Environment="CATALINA_TMPDIR=/tmp"
Environment="JAVA_OPTS=-Djava.awt.headless=true"

But I'm sure I haven't modified systemd configuration...

Best regards,

JB

View solution in original post