Alfresco + CAS Report errors

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Member II

Alfresco + CAS Report errors

I've configured it, web.xml has changed, and CAS can intercept it, but it's still wrong when the landing is successful.

4 Replies
Highlighted
Established Member

Re: Alfresco + CAS Report errors

Hi, 

Looks like you've configured external auth on the repo tier, that's fine but not enough for SSO access on Share.

What about Share configuration for SSO? How is your config on Share tier? This is how is done for Kerberos SSO.

Also, are you aware of Ian's project to integrate CAS and Alfresco (Share and Repo) ?, check this link 

Regards,

Mikel

Highlighted
Member II

Re: Alfresco + CAS Report errors

Thank you. I'll continue to learn.

Highlighted
Member II

Re: Alfresco + CAS Report errors

hi,

I clone your project, but I can't run

Highlighted
Established Member

Re: Alfresco + CAS Report errors

Hi,

It's not my project, it's a well known project in the Alfresco Community to integrate CAS with Alfresco, created by Ian Wright

From the image you sent is hard to tell what's your problem. You can paste your complete log to Pastebin.com - #1 paste tool since 2002! and then referencing here the url 

The general steps will be

A) Configure your CAS endpoints on every pom.xml

B) Build the AMPS

C) Install the AMPS on your installation

On many cases you only want CAS on Share for user SSO access, in that situation you can skip the configure/build/install of the repo amp.

Regards