Alfresco Community 5.2 cifs sharing

cancel
Showing results for 
Search instead for 
Did you mean: 
Fjordo
Member II

Alfresco Community 5.2 cifs sharing

Hello to everyone,

this is my First question, so please forgive me if this ios not the best section to ask.

 

I have an Alfresco Community 5.2 with many documents inside which I have to make them visible to a local CentOS file system trough CIFS.

First of all, is this Alfresco Version still compatible with CIFS File Server?

I configured those parameters on alfresco-global.properties, but nothing happens when I try to connect to the share folder trhough smbclient command.

cifs.enabled=true
cifs.serverName=AlfrescoCIFS
cifs.hostannounce=true
cifs.sessionTimeout=900

cifs.tcpipSMB.port=1445
cifs.netBIOSSMB.namePort=1137
cifs.netBIOSSMB.datagramPort=1138
cifs.netBIOSSMB.sessionPort=1139

Do I miss something? I've followed this guide but without success.

3 Replies

Re: Alfresco Community 5.2 cifs sharing

Did you use default ports?

I mean, internal ports can be 1xxx, but to connect using CIFS you'll need to expose them as 445, 137, 138 and 139.

You can use a firewall for that mapping.

Software Engineer in Alfresco Search Team.
Fjordo
Member II

Re: Alfresco Community 5.2 cifs sharing

I've set these rules to the default ports, but without success

modprobe iptable_nat
iptables -F
iptables -t nat -F
iptables -P INPUT ACCEPT
iptables -P FORWARD ACCEPT
iptables -P OUTPUT ACCEPT
iptables -t nat -A PREROUTING -p tcp --dport 445 -j DNAT --to-destination :1445
iptables -t nat -A PREROUTING -p tcp --dport 139 -j DNAT --to-destination :1139
iptables -t nat -A PREROUTING -p tcp --dport 137:139 -j DNAT --to-destination :1137-1139
iptables -t nat -A PREROUTING -p udp --dport 137:139 -j DNAT --to-destination :1137-1139
jpotts
Advanced II

Re: Alfresco Community 5.2 cifs sharing

I assume you won't run on 5.2 forever, in which case you might as well move from CIFS to AOS and/or WebDAV now.

With that said, have you checked to make sure that the server's native SMB hasn't already grabbed one or more of the ports prior to Alfresco starting up?