Alfresco Community 6.2 on CentOS 7.6 "Failed to connect or to read the response from T-Engine"

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Member II

Alfresco Community 6.2 on CentOS 7.6 "Failed to connect or to read the response from T-Engine"

Hello,
I am in a process of installing alfresco community 6.2 on a CentOS 7.6 VM, I leveraged the instructions available in this link(http://beecon.orderofthebee.net/2017/assets/files/EF09/EF09-Installing-Alfresco-components-1-by-1.pd...).
My Setup:
Alfresco community 6.2
CentOS 7.6
Mariadb 5.5.60
ImageMagic 6.7.8.9
Httpd 2.4.6-88
java 13.0.2
libreOffice 6.4.0.3
Solr6
Tomcat 9.0.30
 
I can't get into share(http://localhost/share) and alfresco(http://localhost/alfresco) i event tried adding port 80, 8080 but not getting any response.
Apache Tomcat log shows "Failed to connect or to read the response from T-Engine...." i have included the command and error message below:
tail -f /space/alfresco-community/tomcat/logs/catalina.out
2020-03-17 19:09:00,032  ERROR [content.transform.LocalTransformServiceRegistry] [QuartzScheduler_Worker-2] 021776511 Failed to connect or to read the response from T-Engine on http://localhost:8090/transform/config
2020-03-17 19:09:00,033  ERROR [content.transform.LocalTransformServiceRegistry] [QuartzScheduler_Worker-2] 021777577 Failed to connect or to read the response from T-Engine on http://localhost:8094/transform/config
2020-03-17 19:09:00,034  ERROR [content.transform.LocalTransformServiceRegistry] [QuartzScheduler_Worker-2] 021777578 Failed to connect or to read the response from T-Engine on http://localhost:8092/transform/config
2020-03-17 19:09:00,036  ERROR [content.transform.LocalTransformServiceRegistry] [QuartzScheduler_Worker-2] 021774810 Failed to connect or to read the response from T-Engine on http://localhost:8093/transform/config
2020-03-17 19:09:00,037  ERROR [content.transform.LocalTransformServiceRegistry] [QuartzScheduler_Worker-2] 021778187 Failed to connect or to read the response from T-Engine on http://localhost:8093/transform/config
2020-03-17 19:09:00,037  ERROR [content.transform.LocalTransformServiceRegistry] [QuartzScheduler_Worker-1] 021775468 Failed to connect or to read the response from T-Engine on http://localhost:8093/transform/config
2020-03-17 19:09:00,038  ERROR [content.transform.LocalTransformServiceRegistry] [QuartzScheduler_Worker-2] 021777168 Failed to connect or to read the response from T-Engine on http://localhost:8093/transform/config
2020-03-17 19:09:00,039  ERROR [content.transform.LocalTransformServiceRegistry] [QuartzScheduler_Worker-2] 021774811 Failed to connect or to read the response from T-Engine on http://localhost:8091/transform/config
2020-03-17 19:09:00,041  ERROR [content.transform.LocalTransformServiceRegistry] [QuartzScheduler_Worker-2] 021778188 Failed to connect or to read the response from T-Engine on http://localhost:8091/transform/config
2020-03-17 19:09:00,047  ERROR [content.transform.LocalTransformServiceRegistry] [QuartzScheduler_Worker-1] 021775469 Failed to connect or to read the response from T-Engine on http://localhost:8091/transform/config
2020-03-17 19:09:00,051  ERROR [content.transform.LocalTransformServiceRegistry] [QuartzScheduler_Worker-2] 021776512 Failed to connect or to read the response from T-Engine on http://localhost:8093/transform/config
2020-03-17 19:09:00,052  ERROR [content.transform.LocalTransformServiceRegistry] [QuartzScheduler_Worker-2] 021776515 Failed to connect or to read the response from T-Engine on http://localhost:8091/transform/config
2020-03-17 19:09:00,053  ERROR [content.transform.LocalTransformServiceRegistry] [QuartzScheduler_Worker-2] 021776516 Failed to connect or to read the response from T-Engine on http://localhost:8094/transform/config
2020-03-17 19:09:00,053  ERROR [content.transform.LocalTransformServiceRegistry] [QuartzScheduler_Worker-2] 021776517 Failed to connect or to read the response from T-Engine on http://localhost:8092/transform/config
2020-03-17 19:09:00,055  ERROR [content.transform.LocalTransformServiceRegistry] [QuartzScheduler_Worker-2] 021777171 Failed to connect or to read the response from T-Engine on http://localhost:8091/transform/config
2020-03-17 19:09:00,056  ERROR [content.transform.LocalTransformServiceRegistry] [QuartzScheduler_Worker-2] 021774814 Failed to connect or to read the response from T-Engine on http://localhost:8094/transform/config
2020-03-17 19:09:00,059  ERROR [content.transform.LocalTransformServiceRegistry] [QuartzScheduler_Worker-2] 021778191 Failed to connect or to read the response from T-Engine on http://localhost:8094/transform/config
2020-03-17 19:09:00,061  ERROR [content.transform.LocalTransformServiceRegistry] [QuartzScheduler_Worker-1] 021775470 Failed to connect or to read the response from T-Engine on http://localhost:8094/transform/config
2020-03-17 19:09:00,062  ERROR [content.transform.LocalTransformServiceRegistry] [QuartzScheduler_Worker-2] 021777172 Failed to connect or to read the response from T-Engine on http://localhost:8094/transform/config
2020-03-17 19:09:00,063  ERROR [content.transform.LocalTransformServiceRegistry] [QuartzScheduler_Worker-2] 021774815 Failed to connect or to read the response from T-Engine on http://localhost:8092/transform/config
2020-03-17 19:09:00,084  ERROR [content.transform.LocalTransformServiceRegistry] [QuartzScheduler_Worker-2] 021778193 Failed to connect or to read the response from T-Engine on http://localhost:8092/transform/config
2020-03-17 19:09:00,103  ERROR [content.transform.LocalTransformServiceRegistry] [QuartzScheduler_Worker-2] 021777175 Failed to connect or to read the response from T-Engine on http://localhost:8092/transform/config
2020-03-17 19:09:00,108  ERROR [content.transform.LocalTransformServiceRegistry] [QuartzScheduler_Worker-1] 021775471 Failed to connect or to read the response from T-Engine on http://localhost:8092/transform/config
 
Also when I stop tomcat I get this:
Using CATALINA_BASE:   /space/alfresco-community/tomcat
Using CATALINA_HOME:   /space/alfresco-community/tomcat
Using CATALINA_TMPDIR: /space/alfresco-community/tomcat/temp
Using JRE_HOME:        /usr
Using CLASSPATH:       /space/alfresco-community/tomcat/bin/bootstrap.jar:/space/alfresco-community/tomcat/bin/tomcat-juli.jar
NOTE: Picked up JDK_JAVA_OPTIONS:  --add-opens=java.base/java.lang=ALL-UNNAMED --add-opens=java.base/java.io=ALL-UNNAMED --add-opens=java.rmi/sun.rmi.transport=ALL-UNNAMED
Mar 17, 2020 7:11:21 PM org.apache.catalina.startup.Catalina stopServer
SEVERE: Could not contact [localhost:8005] (base port [8005] and offset [0]). Tomcat may not be running.
Mar 17, 2020 7:11:21 PM org.apache.catalina.startup.Catalina stopServer
SEVERE: Error stopping Catalina
java.net.ConnectException: Connection refused
        at java.base/sun.nio.ch.Net.connect0(Native Method)
        at java.base/sun.nio.ch.Net.connect(Net.java:493)
        at java.base/sun.nio.ch.Net.connect(Net.java:482)
        at java.base/sun.nio.ch.NioSocketImpl.connect(NioSocketImpl.java:588)
        at java.base/java.net.SocksSocketImpl.connect(SocksSocketImpl.java:339)
        at java.base/java.net.Socket.connect(Socket.java:603)
        at java.base/java.net.Socket.connect(Socket.java:552)
        at java.base/java.net.Socket.<init>(Socket.java:475)
        at java.base/java.net.Socket.<init>(Socket.java:249)
        at org.apache.catalina.startup.Catalina.stopServer(Catalina.java:513)
        at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
        at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at java.base/java.lang.reflect.Method.invoke(Method.java:567)
        at org.apache.catalina.startup.Bootstrap.stopServer(Bootstrap.java:389)
        at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:479)
  
  
But it seems to be stating normal:
[root@Alfresco-Community tomcat]# /space/alfresco-community/tomcat/bin/catalina.sh start
Using CATALINA_BASE:   /space/alfresco-community/tomcat
Using CATALINA_HOME:   /space/alfresco-community/tomcat
Using CATALINA_TMPDIR: /space/alfresco-community/tomcat/temp
Using JRE_HOME:        /usr
Using CLASSPATH:       /space/alfresco-community/tomcat/bin/bootstrap.jar:/space/alfresco-community/tomcat/bin/tomcat-juli.jar
Tomcat started.
 
Here is my global properties file:
#repository location
dir.root=/space/alfresco-community/alf_data
# Sample database connection properties
db.driver=com.mysql.jdbc.Driver
db.username=alfresco
db.password=alfresco
db.name=alfresco
db.url=jdbc:mysql://localhost/alfresco
alfresco.context=alfresco
alfresco.host=127.0.0.1
alfresco.port=8080
alfresco.protocol=http
cifs.enabled=false
ftp.enabled=false
imap.server.enabled=false
alfresco.rmi.services.host=0.0.0.0
monitor.rmi.service.port=0
index.subsystem.name=noindex
 
index.subsystem.name=solr6
solr.host=127.0.0.1
solr.port=8983
solr.port.ssl=8984
solr.secureComms=none

share.context=share
share.host=127.0.0.1
share.port=7080
share.protocol=http
img.root=/usr/share/doc/imagemagick
img.exe=/usr/bin/convert
img.config=${img.root}
img.coders=/usr/lib64/ImageMagick-6.7.8/modules-Q16/coders
img.dyn=/usr/local/lib
img.gslib=/usr/local/lib

ooo.enabled=true
ooo.port=8100
ooo.host=127.0.0.1
alfresco.host=127.0.0.1
alfresco.port=80
share.host=127.0.0.1
share.port=80
transform.service.enabled=false
local.transform.service.enabled=false
legacy.transform.service.enabled=false
 
 
And this is my solr logs:

[root@Alfresco-Community logs]# tail -f /space/solr6/logs/solr.log
        at org.eclipse.jetty.server.HttpConnection.onFillable(HttpConnection.java:251)
        at org.eclipse.jetty.io.AbstractConnection$ReadCallback.succeeded(AbstractConnection.java:273)
        at org.eclipse.jetty.io.FillInterest.fillable(FillInterest.java:95)
        at org.eclipse.jetty.io.SelectChannelEndPoint$2.run(SelectChannelEndPoint.java:93)
        at org.eclipse.jetty.util.thread.strategy.ExecuteProduceConsume.executeProduceConsume(ExecuteProduceConsume.java:303)
        at org.eclipse.jetty.util.thread.strategy.ExecuteProduceConsume.produceConsume(ExecuteProduceConsume.java:148)
        at org.eclipse.jetty.util.thread.strategy.ExecuteProduceConsume.run(ExecuteProduceConsume.java:136)
        at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(QueuedThreadPool.java:671)
        at org.eclipse.jetty.util.thread.QueuedThreadPool$2.run(QueuedThreadPool.java:589)
        at java.base/java.lang.Thread.run(Thread.java:830)
  
  
Any inputs will be appreciated.
Note: my Linux skills are basic to intermediate.
 
 
5 Replies
Highlighted
Established Member II

Re: Alfresco Community 6.2 on CentOS 7.6 "Failed to connect or to read the response from T-Eng

This guide is for Alfresco 5.2. I don't know whether it's possible to install Alfresco 6.2 "the old way". I haven't heard of anybody trying nor I know about a guide fot this.

Your problem here, is that Alfresco expects the T-engines, but you installed transformation software directly. 

You should read about changes in this new release. Maybe you could install T-engines without the docker wrapping, but you should familiarize first with all the components that are expected to be found in a 6.2 Alfresco installation.

You could start with this project as a PoC to understand all the pieces that make Alfresco work. 

Hope it helps! 

 

Highlighted
Member II

Re: Alfresco Community 6.2 on CentOS 7.6 "Failed to connect or to read the response from T-Eng

T-engines conflict

look in that direction

 

 

 

 

 

 

 

 

 

Highlighted
Member II

Re: Alfresco Community 6.2 on CentOS 7.6 "Failed to connect or to read the response from T-Eng

Hi,

Thank you for your input, actually i have read in another discussion that same steps still apply to 6.2 but i don't know.

it seems like T-Engine code is available on github but i have no idea how and where to start.

https://github.com/Alfresco/alfresco-transform-core

My setup is not a docker setup and it looks like it's only for docker, Maven! i have close to zero experience in Maven though.

Thank you,

Highlighted
Member II

Re: Alfresco Community 6.2 on CentOS 7.6 "Failed to connect or to read the response from T-Eng

Thank you,

Highlighted
Established Member II

Re: Alfresco Community 6.2 on CentOS 7.6 "Failed to connect or to read the response from T-Eng

IMO T-engines should work outside docker, as long as you install the software they use on your host.

You could start by downloading the artifacts from here

Then you should install all the software that is installed inside the docker images. So you should navigate to all the Dockerfiles and install the same packages.

There are some extra changes to add to you setup, but I think to make a T-engine work outside docker could be a good starting point. 

Hope it helps