Alfresco Community (Build: 6.0.0-ea) doesn't start

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Member II

Alfresco Community (Build: 6.0.0-ea) doesn't start

Hi Guys

we have Alfresco Community by 2017 and some days ago the website went down. Now I can see this error in Alfresco log:

 

2020-07-10 11:57:22,449 WARN [org.hibernate.cfg.SettingsFactory] [localhost-startStop-1] Could not obtain connection metadata
org.apache.commons.dbcp.SQLNestedException: Cannot create PoolableConnectionFactory (The connection attempt failed.)
at org.apache.commons.dbcp.BasicDataSource.createPoolableConnectionFactory(BasicDataSource.java:1549)
at org.apache.commons.dbcp.BasicDataSource.createDataSource(BasicDataSource.java:1388)
at org.apache.commons.dbcp.BasicDataSource.getConnection(BasicDataSource.java:1044)
at org.springframework.orm.hibernate3.LocalDataSourceConnectionProvider.getConnection(LocalDataSourceConnectionProvider.java:83)
at org.hibernate.cfg.SettingsFactory.buildSettings(SettingsFactory.java:84)
at org.hibernate.cfg.Configuration.buildSettings(Configuration.java:2079)
at org.hibernate.cfg.Configuration.buildSessionFactory(Configuration.java:1304)
at .....

I tried to connect mself to postgres db but no way

If I restart the server just the mobile application is running.... 

Anyone of you can give me support please?

 

Thanks

6 Replies
Highlighted
Community Manager
Community Manager

Re: Alfresco Community (Build: 6.0.0-ea) doesn't start

Hi @giuseppemoglia,

Just to confirm - you have tried and failed to connect to postgres? Can you connect to the database server from a command line?

Take care, 

Digital Community Manager, Alfresco Software.
Problem solved? Click Accept as Solution!
Highlighted
Member II

Re: Alfresco Community (Build: 6.0.0-ea) doesn't start

postrgres process is up but I cannot connect neither from command line...

Highlighted
Community Manager
Community Manager

Re: Alfresco Community (Build: 6.0.0-ea) doesn't start

Hi @giuseppemoglia,

Can you check that the ports haven't changed or firewall rules? You can check is postgres is listening on 5432 port using netstat -a command or 

sudo netstat -ltnp | grep postgres

on linux. 

HTH,

Digital Community Manager, Alfresco Software.
Problem solved? Click Accept as Solution!
Highlighted
Member II

Re: Alfresco Community (Build: 6.0.0-ea) doesn't start

postgres.png

 

 

I've disabled the Firewall 

The port is open

from ntstat -ano the port is open

The strange issue is at start from mobile app it works.....

 

Highlighted
Member II

Re: Alfresco Community (Build: 6.0.0-ea) doesn't start

Also webdav runs

Just share doesn't works correctly

Any hints?

Thanks

Highlighted
Community Manager
Community Manager

Re: Alfresco Community (Build: 6.0.0-ea) doesn't start

Hi @giuseppemoglia,

It's looking like a database issue - perhaps it's corrupted?  Could you try restarting it against a DB backup from before the crash?

Best wishes,

Digital Community Manager, Alfresco Software.
Problem solved? Click Accept as Solution!