Alfresco fails while starting

cancel
Showing results for 
Search instead for 
Did you mean: 
Active Member

Alfresco fails while starting

Hello community!

I installed alfresco from the distribution.zip (alfresco-content-services-community-distribution-6.2.0-ga) like described here: https://docs.alfresco.com/community/concepts/install-zip-overview.html

Environment:

  • JDK 11
  • Tomcat 9.0.34 (I know it's unsupported, but don't belief that it causes my error)
  • PostgreSQL 11.7

When I startup Tomcat I see the following error in the log:

 

2020-04-16 11:39:54,217  WARN  [heartbeat.datasender.HBDataSenderServiceBuilder] [main] Setting the Heartbeat sender cron with property 'heartbeat.sender.cronExpression' is no longer supported.
2020-04-16 11:39:54,498  INFO  [domain.schema.SchemaBootstrap] [main] Ignoring script patch (post-Hibernate): patch.db-V4.2-metadata-query-indexes
2020-04-16 11:39:54,498  INFO  [domain.schema.SchemaBootstrap] [main] Ignoring script patch (post-Hibernate): patch.db-V5.1-metadata-query-indexes
2020-04-16 11:39:54,498  INFO  [domain.schema.SchemaBootstrap] [main] Ignoring script patch (post-Hibernate): patch.db-V5.2-remove-jbpm-tables-from-db
2020-04-16 11:39:54,966  INFO  [alfresco.repo.admin] [main] Using database URL 'jdbc:postgresql://localhost:5432/alfresco' with user 'alfresco'.
2020-04-16 11:39:54,966  INFO  [alfresco.repo.admin] [main] Connected to database PostgreSQL version 11.7
2020-04-16 11:39:58,023  WARN  [context.support.XmlWebApplicationContext] [main] Exception encountered during context initialization - cancelling refresh attempt: org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'transformer.PdfBox' defined in class path resource [alfresco/content-services-context.xml]: Cannot resolve reference to bean 'pdfBoxPDFParserConfig' while setting bean property 'pdfParserConfig'; nested exception is org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'pdfBoxPDFParserConfig' defined in class path resource [alfresco/content-services-context.xml]: Unexpected exception during bean creation; nested exception is java.lang.NullPointerException
2020-04-16 11:39:58,335  ERROR [web.context.ContextLoader] [main] Context initialization failed

Digging deeper I found this part in the mentioned content-services-context.xml:

	<bean id="transformer.PdfBox"
		class="org.alfresco.repo.content.transform.PdfBoxContentTransformer"
		parent="baseTikaContentTransformer">
		<property name="documentSelector" ref="pdfBoxEmbededDocumentSelector" />
		<property name="pdfParserConfig" ref="pdfBoxPDFParserConfig"/>
		<property name="extractBookmarksText">
			<value>${content.transformer.PdfBox.extractBookmarksText}</value>
		</property>
	</bean>
	
	<bean id="pdfBoxPDFParserConfig" class="org.apache.tika.parser.pdf.PDFParserConfig">
	</bean>

Can someone please tell me why the creation of the Bean fails?

Is a certain component missing that I didn't install? It seems that the DB connection is working but until this point apperently no tables are created...

 

 

7 Replies
Active Member

Re: Alfresco fails while starting

I think this is the root cause:

Caused by: java.lang.NullPointerException
	at org.apache.tika.parser.pdf.PDFParserConfig.hashCode(PDFParserConfig.java:749)

BTW: In the meantime I installed from alfresco-content-services-community-distribution-6.1.2-ga and it shows the exact same behaviour... :-(

Active Member

Re: Alfresco fails while starting

I must admit that I was wrong.

The errors I described above are related to tomcat 9. As soon as I used 8.5.54 the errors disapeared. I guess this is a Spring / Tomcat 9 problem.

Active Member

Re: Alfresco fails while starting

i managed to get up and running, 

 

what i did was a bit strange but i thought rolling back to an older version 6.0.5 might work, so i downloaded the YML and did a compose-up

the whole thing downloaded successfully but i accidently had an old container for 6.1.2 GA running. so it didn't start frustratingly

 

after a bit of stuffing around i ended up re-downloading the YML for 6.1.2 and did a compose up 

 

the whole thing worked

Active Member

Re: Alfresco fails while starting

I can't see how this is related to the error I described. I'm not using Docker. I installed from the distribution.zip into an existing tomcat 9 server.

Community Manager
Community Manager

Re: Alfresco fails while starting

Hi @akreienbring,

Glad you got it working & thanks for reporting back - helpful to other users. 

Digital Community Manager, Alfresco Software.
Problem solved? Click Accept as Solution!
Active Member

Re: Alfresco fails while starting

i think we found it, the machine settings on docker were not sufficient, once we upped it to 6Gb ram everything came to life on multiple machines i.e. windows PC and also on a MAC.

 

i think it would be really handy to include the minimum docker settings on the community download page.

 

thanks all

 

Community Manager
Community Manager

Re: Alfresco fails while starting

Hi @qc-technology,

Glad you got it sorted & for reporting back. I'll take a look at the documentation.

Cheers, 

Digital Community Manager, Alfresco Software.
Problem solved? Click Accept as Solution!