Alfresco Rules occasionally don't fire

cancel
Showing results for 
Search instead for 
Did you mean: 
fabiocilento
Member II

Alfresco Rules occasionally don't fire

I have an Alfresco installation where i use rules in order to fire workflows when user loads document in a specific folder.

The system has been in exercise for about two months, having about 20 concurrent users every day. Now there are about 20000 documents. 

What is happen now is that occasionally rules don't fire when user upload a document; "occasionally" means that doessn't depend on which document is loaded or in what folder, and neither what rule is associated to a folder.

In order to debug it I've created a folder having a simple rule that converts a document in pdf, this way i can stress-test it loading many documents at a time in that folder expecting to two-folde the number, for example i load five file .doc and i wait to see in the folder five .doc and five .pdf.

what happens is that sometimes i have four .pdf, sometimes two, sometimes none. I have also added another rule executing a log script and what i see is that neither this rule is triggered. 

If i upload my files in another folder (having no rules)  and then a move those in the "ruled" folder rules are always triggered.

It seems that sometimes Alfresco doesn't catch the upload event. 

When i restart Alfresco rules start working again for a period that i think depends on the workload of the system.

This happens only in production, in development and test environment has never happened.

 

What could be the cause of this behaviour?

Thanks

Alfresco Community 6.0.7

Ubuntu 18.04.2 

3 Replies

Re: Alfresco Rules occasionally don't fire

Those 20,000 documents are stored on the same folder? On the folder where the rule is defined?

What is doing that rule?

Software Engineer in Alfresco Search Team.
fabiocilento
Member II

Re: Alfresco Rules occasionally don't fire

Thanks angelborroy,

20000 are about all the documents stored in the system, not only in a folder, moreover the fault doesn't depend on the folder or on a specific rule, I also tried creating a simple rule that just call a script that logs the name of the document uploaded; what happens is that sometimes the rule doesn't trigger when i upload a file via Share or webdav, regardless of the document type or extension or size, while if I upload the file in another folder with no rules, and then move the document in the "ruled" folder using Share, rules always trigger. I don't know if there is a way to log the upload event; it seems that sometimes the upload event is not catched.

fabiocilento
Member II

Re: Alfresco Rules occasionally don't fire

What i've noticed enabling specific logs is that when rule doesn't work o.a.r.r.ruletrigger.CreateNodeRuleTrigger doesn't log anything.

This fault has become very important to solve because the whole project is based on alfresco rules.

Do you have any idea for debug it?