Alfresco search is not working. It search just peoples

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
luizniero
Active Member

Alfresco search is not working. It search just peoples

Jump to solution

Im using Alfresco community 5.2. I did the wizzard instalation, but i soo that the search (normal and advanced option) is not working. When i try to search something, alfresco return just peoples.

1 Solution

Accepted Solutions
luizniero
Active Member

Re: Alfresco search is not working. It search just peoples

Jump to solution

I find the problem. My solr configuration in alfresco-global.properties was wrong.

I followed it

https://docs.alfresco.com/5.2/tasks/solr4-alfresco-config.html

And now its running.

Thank You

View solution in original post

5 Replies
abbask01
Established Member II

Re: Alfresco search is not working. It search just peoples

Jump to solution

It looks like your solr is not configured properly. do you get any errors related to solr on startup?

Regards,
Abbas
luizniero
Active Member

Re: Alfresco search is not working. It search just peoples

Jump to solution

No erros on startup, but i do not configured solr, i did the common wizard instalation

luizniero
Active Member

Re: Alfresco search is not working. It search just peoples

Jump to solution

I find the problem. My solr configuration in alfresco-global.properties was wrong.

I followed it

https://docs.alfresco.com/5.2/tasks/solr4-alfresco-config.html

And now its running.

Thank You

View solution in original post

christuira
Member II

Re: Alfresco search is not working. It search just peoples

Jump to solution

I have the same problem, and i've configured as described in the link provided, but still does not work. Live search works though, returning user accounts only. Does anyone have an idea where else i could check?

### Solr indexing ###
index.subsystem.name=solr4
dir.keystore=${dir.root}/keystore
solr.host=localhost
solr.port=8080
solr.port.ssl=8443
#solr.query.maximumResultsFromUnlimitedQuery=10000
#system.acl.maxPermissionChecks=10000

christuira
Member II

Re: Alfresco search is not working. It search just peoples

Jump to solution

I fixed my problem: I have a custom type and property names starting with a number. I read somewhere there is a bug like this, and apparently exists in the alfresco version im using: Alfresco Community v5.2.0 (r135134-b14). Created new type and properties with fixed names, and reuploaded affected files with fixed metadata.