Alfresco Solr "aclchangesets return status:403"

cancel
Showing results for 
Search instead for 
Did you mean: 
Jess_js
Active Member

Alfresco Solr "aclchangesets return status:403"

Jump to solution

Hello,

I've created a maven project with alfresco-allinone-archetype 4.4.0 and I've a clean Alfresco.

Starting the project with .\run.bat build_start I'm getting this error from Solr:

docker-nutella-acs-1 | 12-Apr-2022 10:54:15.943 INFO [main] org.apache.catalina.startup.HostConfig.deployDirectory Deploying web application directory [/usr/local/tomcat/webapps/ROOT]
docker-nutella-acs-1 | 12-Apr-2022 10:54:15.958 WARNING [main] org.apache.tomcat.util.digester.SetPropertiesRule.begin Match [Context] failed to
set property [debug] to [100]
docker-nutella-acs-1 | 12-Apr-2022 10:54:16.137 INFO [main] org.apache.jasper.servlet.TldScanner.scanJars At least one JAR was scanned for TLDs yet contained no TLDs. Enable debug logging for this logger for a complete list of JARs that were scanned but no TLDs were found in them. Skipping unneeded JARs during scanning can improve startup time and JSP compilation time.
docker-nutella-acs-1 | 12-Apr-2022 10:54:16.144 INFO [main] org.apache.catalina.startup.HostConfig.deployDirectory Deployment of web application
directory [/usr/local/tomcat/webapps/ROOT] has finished in [200] ms
docker-nutella-acs-1 | 12-Apr-2022 10:54:16.165 INFO [main] org.apache.coyote.AbstractProtocol.start Starting ProtocolHandler ["http-nio-8080"]
docker-nutella-acs-1 | 12-Apr-2022 10:54:16.219 INFO [main] org.apache.catalina.startup.Catalina.start Server startup in [126593] milliseconds
docker-nutella-ass-1 | 2022-04-12 10:54:16.841 ERROR (searcherExecutor-7-thread-1-processing-x:alfresco) [ x:alfresco] o.a.s.t.AbstractTracker
Model tracking failed for core: alfresco
docker-nutella-ass-1 | org.alfresco.error.AlfrescoRuntimeException: 03120000 alfresco GetModelsDiff return status is 403
docker-nutella-ass-1 | at org.alfresco.solr.client.SOLRAPIClient.getModelsDiff(SOLRAPIClient.java:1181)
docker-nutella-ass-1 | at org.alfresco.solr.tracker.ModelTracker.trackModelsImpl(ModelTracker.java:291)
docker-nutella-ass-1 | at org.alfresco.solr.tracker.ModelTracker.trackModels(ModelTracker.java:249)
docker-nutella-ass-1 | at org.alfresco.solr.tracker.ModelTracker.ensureFirstModelSync(ModelTracker.java:271)
docker-nutella-ass-1 | at org.alfresco.solr.lifecycle.SolrCoreLoadRegistration.registerForCore(SolrCoreLoadRegistration.java:110)
docker-nutella-ass-1 | at org.alfresco.solr.lifecycle.SolrCoreLoadListener.newSearcher(SolrCoreLoadListener.java:44)
docker-nutella-ass-1 | at org.apache.solr.core.SolrCore.lambda$getSearcher$15(SolrCore.java:2249)
docker-nutella-ass-1 | at java.util.concurrent.FutureTask.run(FutureTask.java:266)
docker-nutella-ass-1 | at org.apache.solr.common.util.ExecutorUtil$MDCAwareThreadPoolExecutor.lambda$execute$0(ExecutorUtil.java:229)
docker-nutella-ass-1 | at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
docker-nutella-ass-1 | at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
docker-nutella-ass-1 | at java.lang.Thread.run(Thread.java:748)
docker-nutella-ass-1 | 2022-04-12 10:54:20.040 ERROR (org.alfresco.solr.AlfrescoCoreAdminHandler@29a5f4e7_Worker-3) [ ] o.a.s.t.AbstractTracker Tracking failed for AclTracker - archive
docker-nutella-ass-1 | org.alfresco.error.AlfrescoRuntimeException: 03120001 api/solr/aclchangesets return status:403
docker-nutella-ass-1 | at org.alfresco.solr.client.SOLRAPIClient.getAclChangeSets(SOLRAPIClient.java:169)
docker-nutella-ass-1 | at org.alfresco.solr.tracker.AclTracker.checkRepoAndIndexConsistency(AclTracker.java:326)
docker-nutella-ass-1 | at org.alfresco.solr.tracker.AclTracker.trackRepository(AclTracker.java:303)
docker-nutella-ass-1 | at org.alfresco.solr.tracker.AclTracker.doTrack(AclTracker.java:95)
docker-nutella-ass-1 | at org.alfresco.solr.tracker.AbstractTracker.track(AbstractTracker.java:215)
docker-nutella-ass-1 | at org.alfresco.solr.tracker.TrackerJob.execute(TrackerJob.java:47)
docker-nutella-ass-1 | at org.quartz.core.JobRunShell.run(JobRunShell.java:216)
docker-nutella-ass-1 | at org.quartz.simpl.SimpleThreadPool$WorkerThread.run(SimpleThreadPool.java:563)

What can it be caused by? How can it be solved?

Looking forward to a cordial reply, thank you in advance.

1 Solution

Accepted Solutions
angelborroy
Alfresco Employee
5 Replies
angelborroy
Alfresco Employee

Re: Alfresco Solr "aclchangesets return status:403"

Jump to solution

This is an issue for the SDK that will be fixed in future releases.

"none" (plain http) communication mode for Repo & Solr is not allowed from ACS 7.2. You may change that configuration manually in your Docker Compose file.

Hyland Developer Evangelist
Jess_js
Active Member

Re: Alfresco Solr "aclchangesets return status:403"

Jump to solution

Hi angelborroy, thanks.

How can I change this configuration? I'm using the default docker-compose.yml file.
Is an https communication also required for a test environment?

angelborroy
Alfresco Employee
Jess_js
Active Member

Re: Alfresco Solr "aclchangesets return status:403"

Jump to solution

Thank you so much for your help, I solved the issue.

agermain
Customer

Re: Alfresco Solr "aclchangesets return status:403"

Jump to solution

Can I ask how did you resolved this issue ? 

I am using the AIO 4.4. I'm just trying to make it work out of the box. 

I added this to the alfresco-global.properties :

index.subsystem.name=solr6
solr.host=alfresco-xxx-ass
solr.port=8983
solr.secureComms=secret
solr.sharedSecret=secret

I also added this to my docker-compose.yml

 

 alfresco-xxx-ass:
    image: alfresco/alfresco-search-services:1.2.0
    environment:
      SOLR_ALFRESCO_HOST: alfresco-xxx-acs
      SOLR_ALFRESCO_PORT: 8080
      SOLR_SOLR_HOST: alfresco-xxx-ass
      SOLR_SOLR_PORT: 8983
      SOLR_CREATE_ALFRESCO_DEFAULTS: alfresco,archive
      SOLR_OPTS: "
      -Dalfresco.securecomms=secret
      -Dalfresco.secureComms.secret=secret
      "
    ports:
      - "8983:8983"
    volumes:
      - alfresco-xxx-ass-volume:/opt/alfresco-search-services/contentstore
      - alfresco-xxx-ass-volume:/opt/alfresco-search-services/data

The problem is that solr doesn't seem to change his secure comms method. I still can acces solr url whitout the secret header and I still get this stacktrace : 

 

 

 

2022-06-29 20:41:40.045 ERROR (org.alfresco.solr.AlfrescoCoreAdminHandler@29a5f4e7_Worker-2) [ ] o.a.s.t.AbstractTracker Tracking failed for AclTracker - alfresco
alfresco-xxx-ass_1 | org.alfresco.error.AlfrescoRuntimeException: 05290002 api/solr/aclchangesets return status:403
alfresco-xxx-ass_1 | at org.alfresco.solr.client.SOLRAPIClient.getAclChangeSets(SOLRAPIClient.java:169)
alfresco-xxx-ass_1 | at org.alfresco.solr.tracker.AclTracker.checkRepoAndIndexConsistency(AclTracker.java:326)
alfresco-xxx-ass_1 | at org.alfresco.solr.tracker.AclTracker.trackRepository(AclTracker.java:303)
alfresco-xxx-ass_1 | at org.alfresco.solr.tracker.AclTracker.doTrack(AclTracker.java:95)
alfresco-xxx-ass_1 | at org.alfresco.solr.tracker.AbstractTracker.track(AbstractTracker.java:215)
alfresco-xxx-ass_1 | at org.alfresco.solr.tracker.TrackerJob.execute(TrackerJob.java:47)
alfresco-xxx-ass_1 | at org.quartz.core.JobRunShell.run(JobRunShell.java:216)
alfresco-xxx-ass_1 | at org.quartz.simpl.SimpleThreadPool$WorkerThread.run(SimpleThreadPool.java:563)

 

Did someone have an idea how can I resolve this issue ? 

Thank you 

AG.

 

SOLVED :  For those wondering, I fixed this issue by following theses steps : Search Services 1.2 throw error 403 with ACS 7.2 · Issue #635 · Alfresco/alfresco-sdk (github.com)