Alfresco upgrade issue

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Active Member

Alfresco upgrade issue

I'm running into an error after upgrading Alfresco from 4.2 to the latest version. Since the installer wouldn't allow me to overwrite the original Alfresco 4.2 install directory (/opt/alfresco), I created a new folder (/opt/alfresco-new). At the Alfresco homepage (https://localhost:8443/), I get the following error: 

Attached is my Alfresco log. During the install, I opted to use my own JAVA JRE and PostgreSQL installs. The PostgreSQL DB I'm using is the exact same from v4.2. Would I by any chance need to link the alf_data directory in my new install with the old for the Alfresco Repository to work?

1 Reply
Senior Member II

Re: Alfresco upgrade issue

Alfresco is storing data on two places.

  • alf_data   : Here all the documents are stored
  • database : It stores the properties related to document and many other things.

So if this both things are not synced than it will throw the exception while starting the server which is happening in your case

It seems like your new alfresco points to an old database and the new alf_data.This will create problem.You should delete alf_data and create new database or make the old database blank one.

If you have some important data and it will delete all the documents so use this carefully.