Alfresco won't start: Postgresql log says: "Fatal: Database system starting up"

cancel
Showing results for 
Search instead for 
Did you mean: 
lcardon
Member II

Alfresco won't start: Postgresql log says: "Fatal: Database system starting up"

Jump to solution

I have a Windows 10 stand alone machine that I have been running Alfresco on for over a year with no problems.

This morning somebody started messing with electricity in the building and inadvertently shut power off to the machine in question, thereby killing the machine without proper shut-down.

The machine starts and runs ok, but now the Postgresql service will not start and subsequently the tomcat service will not start either (I assume because the database will not start).

I have checked the most recent Postgresql.log and the only thing listed is:

FATAL: Database system starting up.

In the Community Manager the Application Log tab says:

"Starting Postgres... Exit Code: 1"

I have no idea what needs to happen to get this Alfresco / Postgresql database back to starting up and working.

Please point me to a procedure page, or please help. Critical app now at this location.

Thanks.

 

1 Solution

Accepted Solutions
jpbuttet
Active Member II

Re: Alfresco won't start: Postgresql log says: "Fatal: Database system starting up"

Jump to solution

If you don't find any better solution, you could see if starting postgres in single mode helps.

I would check postgresql doc: https://www.postgresql.org/docs/

and see if you could go like this way:

https://www.cryptomonkeys.com/2017/03/postgres-wont-start/

 

You should make sure your UPS is okay and hope you have a recent backup.

 

 

View solution in original post

3 Replies
jpbuttet
Active Member II

Re: Alfresco won't start: Postgresql log says: "Fatal: Database system starting up"

Jump to solution

If you don't find any better solution, you could see if starting postgres in single mode helps.

I would check postgresql doc: https://www.postgresql.org/docs/

and see if you could go like this way:

https://www.cryptomonkeys.com/2017/03/postgres-wont-start/

 

You should make sure your UPS is okay and hope you have a recent backup.

 

 

View solution in original post

lcardon
Member II

Re: Alfresco won't start: Postgresql log says: "Fatal: Database system starting up"

Jump to solution

The solution posted worked well in my case.

Note: Just by way of clarification.

If you need to use this method, the SingleUser Mode performs some type of Database Check. It also informed me (by chance?) that the database had been terminated incorrectly (the power went down abruptly). It realigned everything and the problem was resolved.

1. I am running on Windows so. I opened a command prompt and was able to run the Single User startup from the Command Line

2. In the instructions be careful to locate on your machine which folders are correct (Postgres folder and Data folder). I am using Postgress with Alfresco obviously so the info in the instructions is varied slightly.

3. I will shortly be moving from a physical machine to a Virtual machine. This project originally started as a test, so we just installed on a standalone Windows 10 machine. In my case it would have been good to have the machine setup with some type of UPS and the problem would have been avoided altogether.

4. Make sure you have good backups - Even if this procedure had not worked I'm confident we could have brought Alfresco back up with the backups I kept.

 

jpbuttet
Active Member II

Re: Alfresco won't start: Postgresql log says: "Fatal: Database system starting up"

Jump to solution

Hello,

 

Glad to see that your database is back again and thank you for your feedback. 

 

Best regards.