Alfreso Share translations problem

cancel
Showing results for 
Search instead for 
Did you mean: 
upforsin
Senior Member

Alfreso Share translations problem

Jump to solution

Hello,

I have alfresco-jp.jar and share-jp.jar (custom translations from Crowdin). When I trow it under webapps/alfresco/WEB-INF/lib/ and webapps/share/WEB-INF/lib/ they work perfectly.

But when thrown in the web-server/shared/ directory with the shared.loader property set - only some translations work (like 75%)

Does anybody know why is that? Is there a way to have a common directory? I tested it with the Alfresco Community 6.x and 7.x.

1 Solution

Accepted Solutions
angelborroy
Alfresco Employee

Re: Alfreso Share translations problem

Jump to solution

Some of the messages are deployed as extension to Alfresco and Share that requires to be deployed in "WEB-INF/lib" folders. I guess there is no alternative to deploy both in an external library folder.

Hyland Developer Evangelist

View solution in original post

2 Replies
angelborroy
Alfresco Employee

Re: Alfreso Share translations problem

Jump to solution

Some of the messages are deployed as extension to Alfresco and Share that requires to be deployed in "WEB-INF/lib" folders. I guess there is no alternative to deploy both in an external library folder.

Hyland Developer Evangelist
upforsin
Senior Member

Re: Alfreso Share translations problem

Jump to solution

Well... that explains everything, thank you @angelborroy 

As a workaround, I just merged custom translation with the custom amps (put them into the src/main/assembly/lib/ and configured fileSet in the amp.xml)