Any available link for alfresco-remote-api

cancel
Showing results for 
Search instead for 
Did you mean: 
Established Member II

Any available link for alfresco-remote-api

Any available link for alfresco-remote-api that can be compiled and build on jdk 8.

 

I have a link https://github.com/Alfresco/alfresco-remote-api for which i am trying to build the project but getting error :-

 

bad class file: C:\Users\infoadmin\.m2\repository\org\alfresco\alfresco-data-model\8.158\alfresco-data-model-8.158.jar(org/alfresco/model/ContentModel.class)
class file has wrong version 55.0, should be 52.0
Please remove or make sure it appears in the correct subdirectory of the classpath.

 

Before building this project i have changed  <maven.build.sourceVersion>11</maven.build.sourceVersion> to  <maven.build.sourceVersion>8</maven.build.sourceVersion> in pom.xml .. then also error is coming..

 

1- Is there any link or project is there that can be compiled using jdk 8..

2-Or any changes i should do in the pom file of the link above.

 

Please suggest as i am trying very hard.

3 Replies
Moderator
Moderator

Re: Any available link for alfresco-remote-api

Use this repository: https://github.com/Alfresco/alfresco-community-repo

https://github.com/Alfresco/alfresco-community-repo/tree/master/remote-api

The one you are using is archived. 

Make sure you have installed Java11 on your machine, default source version is 11 and you should not change it. 

Oracle jdk-11.0.1 or later/Open JDK 11.0.1 or later is required to build the master branch. 

1- Install java11, open command prompt/shell and check the "java -version". It should indicate the java 11 version.

2- Open command prompt/shell and navigate to the folder "alfresco-community-repo" containing parent pom.xml 

3- execute mvn clean package

mvn clean package -Pcommunity -DskipTests=true -Dversion.edition=Community
~Abhinav
(ACSCE, AWS SAA-C02, GAIQ)
Established Member II

Re: Any available link for alfresco-remote-api

I am using alfresco 5.2 and if I use JDK 11 to build then it is giving error compiled from higher version 55 need 52.

 

Now what we should do. My requirement is to sort workflow by start date for that we need to override the web script TaksInstancesGet

Moderator
Moderator

Re: Any available link for alfresco-remote-api

You have tagged the post with ACS6x too. For 5.2 version you need to use the same repo and find the tag specific to 5.2.x.  Source of the 5.2.x tag can be found here as well, if you want to take a reference: https://artifacts.alfresco.com/nexus/service/local/repositories/releases/content/org/alfresco/alfres...

However, the right way to extend the webscript is to use the extension, it is not required to build the alfresco source project unless you are building your own version of acs with something that can't be done without building your custom build. Check support to make sure this type of version is supported or not if you are using enterprise version. 

Here you can find example of extending an out of the box webscript: https://javaworld-abhinav.blogspot.com/2020/06/change-type-of-custom-content-types.html 

This the webscript you want to extend: https://github.com/Alfresco/alfresco-community-repo/blob/master/remote-api/src/main/resources/alfres...

You can take the reference of above post and extend the webscript if that solves your issue. You can also create your custom webscript and use WorkflowService , This requries UI component to use your custom webscript instead of ootb webscript. 

 

~Abhinav
(ACSCE, AWS SAA-C02, GAIQ)