AOS Office 2016 keeps asking credentials

cancel
Showing results for 
Search instead for 
Did you mean: 
Active Member

AOS Office 2016 keeps asking credentials

As the title suggests;  we are using Community 201612, LDAP auth, SSL via Apache proxy and AOS works fine.

Only issue is that Word and Excel 2016 keeps asking credentials every time you "Edit with Microsoft Office"

Tried adding site to "Trusted Sites" but no change.

Regards

Hans

8 Replies
Active Member II

Re: AOS Office 2016 keeps asking credentials

Hi Hans,

Do you have SSO enabled on your instance? That would solve you problem if you implement it.

~Vusani

Active Member

Re: AOS Office 2016 keeps asking credentials

Hi,

Was thinking of enabling SSO, but the config documentation suggests SSO must be disabled (or does not work) when using LDAP auth?

Authentication subsystem types | Alfresco Documentation 

Hans

Active Member II

Re: AOS Office 2016 keeps asking credentials

You can set multiple auth chains, we have Kerberos and LDAP running together with no problems.

Kerberos handles the SSO I think, and the LDAP handles your normal auth (I might be wrong, but that is how our environment is setup)

See: Configuring the authentication chain | Alfresco Documentation 

~Vusani

Active Member

Re: AOS Office 2016 keeps asking credentials

Ok, will take a look at Kerberos setup again.

Always tried and stay away from that convoluted setup - but sigh, the users want SSO.

Active Member

Re: AOS Office 2016 keeps asking credentials

Hi,

Just to be clear, you followed these steps to get Kerberos SSO working with MS Office 2016?

Enabling Kerberos authentication | Alfresco Documentation 

Hans

Active Member II

Re: AOS Office 2016 keeps asking credentials

Hi,

Yes I did. Be sure to do the java config as well and the "share-config.xml" changes for it to work. Follow the guide diligently.

~Vusani

Active Member II

Re: AOS Office 2016 keeps asking credentials

Hi,

I followed it diligently and kerberos don't want to be my friend...

I am on alfresco 5.2.0

Did you set it and can you give your config files here ?

if possible these files :

- wqsapi-custom.properties (clear pwd)

- alfresco-global.properties

- krb5.conf

- setenv.sh

My crederntials is ok with passthru but with kerberos it always ask me for credentials.

Alfresco server is on trusted sites.

If one of you could help me, i'm on it for weeks and i pass 10 hours / day on it ...

I only have this error 

2018-07-17 17:10:11,889 ERROR [extensions.config.RemoteConfigElement] [localhost-startStop-1] java.io.FileNotFoundException: alfresco/web-extension/alfresco-system.p12 (Aucun fichier ou dossier de ce type)
2018-07-17 17:10:11,892 ERROR [extensions.config.RemoteConfigElement] [localhost-startStop-1] java.io.FileNotFoundException: alfresco/web-extension/ssl-truststore (Aucun fichier ou dossier de ce type)

I didn't create the certificate is that really needed ? 

*Castel*

Member II

Re: AOS Office 2016 keeps asking credentials

I got successful SSO through Apache/mod_kerberos with Office 2016 after disableing modern authentication by setting EnableADAL to 0.

See here: Alfresco, Kerberos and Office 2016 credential pop-ups : Little Impact