Can't log in to Alfresco share UI(PKIX path building failed, unable to find valid certification path

cancel
Showing results for 
Search instead for 
Did you mean: 
Member II

Can't log in to Alfresco share UI(PKIX path building failed, unable to find valid certification path

I am not able to log in to Alfresco Share UI using any userid-password combinations, which are valid.

It allows me to log in to the admin console using that userid-password combination.

 

For example, using that userid-password combination, I can successfully log into:

https://whatever-my-domain-is/alfresco/service/enterprise/admin/admin-systemsummary

 

But I cannot log in to share UI using URL similar to:

https://whatever-my-domain-is/share/page/

When I type the URL above, I get the userid-password login page, where I type in the correct values. However, the login fails to the share UI.

 

The certificate is valid and the certificate has not changed (as I can see the certificate is valid in the URL above). 

 

When I try to log in to the Share UI using thing the userid-password, I get the following error in the share log.

 

[org.springframework.extensions.webscripts.connector.RemoteClient] [http-apr-8080-exec-7] Exception calling (GET)

https://whatever-my-domain-is/alfresco/wcs/remoteadm/has/alfresco/site-data/components/page.tradeMarkLogo.slingshot-login.xml?s=sitestore

[org.springframework.extensions.webscripts.connector.RemoteClient] [http-apr-8080-exec-7]

Error status 500 sun.security.validator.ValidatorException: PKIX path building failed: 


javax.net.ssl.SSLHandshakeException: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
at sun.security.ssl.Alerts.getSSLException(Unknown Source)

 

 

1 Reply
Highlighted
Community Manager
Community Manager

Re: Can't log in to Alfresco share UI(PKIX path building failed, unable to find valid certification

Hi @SG,

Could you provide a little more information about your environment? Also, is this a new issue, was everything previously working ok, etc? What steps have you taken to add certificates, etc?

Thanks, 

Digital Community Manager, Alfresco Software.
Problem solved? Click Accept as Solution!