Can't start Libreoffice on Community 5.2

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Partner

Can't start Libreoffice on Community 5.2

Libreoffice isn't starting automatically. I've searched online and that seems to be a known problem with the startup scripts so I focused on trying to manually start up libreoffice by using the script ./libreoffice_ctl.sh

However the output is ./libreoffice_ctl.sh : libreoffice could not be started and nothing more. I've tried to install libs that are mentioned in various forum posts but it doesn't make a difference.

My configuration in alfresco-global.properties looks like this:

I've attempted to change the flags ooo.enabled and jodconverted.enabled for testing purposes as well.

ooo.exe=/srv/tomcat/alfrescorepo/libreoffice/program/soffice.bin
ooo.enabled=false
ooo.port=8100

jodconverter.enabled=true
jodconverter.officeHome=/srv/tomcat/alfrescorepo/libreoffice
jodconverter.portNumbers=8101,8102  

 

 

4 Replies
Advanced

Re: Can't start Libreoffice on Community 5.2

As far as I know The JODConverter is not available In Community Edition,only OOoDirect is available .

I suggest you to upgrade your alfresco to 6.x and use alfresco transformation service as instead,It is more effective

Highlighted
Partner

Re: Can't start Libreoffice on Community 5.2

Libreoffice is supplied along with Alfresco in the installer for 5.2 Community. If that's the case, shouldn't it be enough to configure the JODConverter enable flag to false and ooo.enabled to true? I've also tried to execute ./soffice and soffice.bin in hope that it would output an error message such as missing libs. However, it just freezes in the terminal without any output. I used CTRL+C to exit out of that state after a bit of waiting...
Highlighted
Community Manager
Community Manager

Re: Can't start Libreoffice on Community 5.2

Hi @phivuu-2,

This thread is about starting libreoffice and there is also some info here.

HTH

Digital Community Manager, Alfresco Software.
Problem solved? Click Accept as Solution!
Highlighted
Partner

Re: Can't start Libreoffice on Community 5.2

It's working now. There were some faults in the script to start libreoffice. Using Jodconverter didn't work with previews so I've enabled the flag ooo.enabled in alfresco-global.properties which solved the preview issue.