Cannot deactivate/delete custom model

cancel
Showing results for 
Search instead for 
Did you mean: 
sirchnait
Active Member

Cannot deactivate/delete custom model

I've been approaching the topic custom models lately. I've created a rudimentary custom model with the model manager from the Admin Tools. Now I wanted to start over agein and delete the first model. However, Alfresco denies deactivating or deleting any component of the model, i.e. no custom type or aspect can't be deleted. On the attempt to remove a property, it says "We couldn't update the model right now. Try sharing the following details with your IT team. Failed to validate property delete, property {modelname}aspectname is in use" - the corresponding exception in the alfresco.log says 

ERROR [org.alfresco.rest.framework.webscripts.ResourceWebScriptPut] [http-nio-8080-exec-7] c3dc2fef-2934-4566-a0ae-edab78ce6369 : [org.alfresco.rest.api.impl.CustomModelsImpl.updateModel(CustomModelsImpl.java:1304), org.alfresco.rest.api.impl.CustomModelsImpl.updateTypeAspect(CustomModelsImpl.java:504), org.alfresco.rest.api.impl.CustomModelsImpl.updateCustomType(CustomModelsImpl.java:460), sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method), sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62), sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43), java.lang.reflect.Method.invoke(Method.java:498), org.springframework.aop.support.AopUtils.invokeJoinpointUsingReflection(AopUtils.java:317) (...)

Trying to deactivate the model results in an error "We couldn't deactivate model ' Model 'xyz' is in use and cannot be deleted or deactivated." The exception in the logfile is very similar to the one above. However, Alfresco shows no results searching for any occurrences of my model and I'm pretty sure that's correct since I applied the type of only one document to my model and deleted this document later on.

Any ideas on how to solve this would be greatly appreciated...

 

2 Replies
kalpesh_c2
Senior Member

Re: Cannot deactivate/delete custom model

Hi,

Did you delete that document from Trashcan? If not, then try after deleting that document from Trashcan.

Thanks,

Kalpesh

ContCentric

sirchnait
Active Member

Re: Cannot deactivate/delete custom model

Hi,

thanks for the answer. I followed your advice and double-checked the trashcan: as owner of the file and again as administrator. The file is gone but the error messages remain the same.

It seem like one has to wait a few seconds - now it's working: I can deactivate and delete my model. Thanks alot!!! Ticket will be market as solved.

Regards,

Christian