Change a model deploy in an amp by a jar

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Active Member

Change a model deploy in an amp by a jar

Jump to solution

Hi,

We have a custom model deploy in an amp. Currently, we've join several amps in the same project and we'd like to deploy as jar. What would be the best steps to uninstall the amp and deploy the jar wihout having issues with the model?

 

Thanks and regards.

1 Solution

Accepted Solutions
Highlighted
Alfresco Employee

Re: Change a model deploy in an amp by a jar

Jump to solution

AMPs are bundled with alfresco.war when using apply-amps tool.

I would take your alfresco.war to a separate environment and I'll undeploy the AMP and deploy the JAR. Just to test that it works. If both AMP and JAR modules have the same module.id and module.version, that would work.

 

Software Engineer in Alfresco Search Team.

View solution in original post

5 Replies
Highlighted
Alfresco Employee

Re: Change a model deploy in an amp by a jar

Jump to solution

AMPs are bundled with alfresco.war when using apply-amps tool.

I would take your alfresco.war to a separate environment and I'll undeploy the AMP and deploy the JAR. Just to test that it works. If both AMP and JAR modules have the same module.id and module.version, that would work.

 

Software Engineer in Alfresco Search Team.

View solution in original post

Highlighted
Active Member

Re: Change a model deploy in an amp by a jar

Jump to solution

Thanks Ángel.

I unistalled the amp and deploy the jar. However I get an error about the some differences found in the model. However, both projects had different module.id. I'm going to use the same module.id and module.version and I'll check it.

 

Highlighted
Active Member

Re: Change a model deploy in an amp by a jar

Jump to solution

Hi,

I'm using the same module.id and module.version. Removed the amp through apply-amps tool and deployd the jar. However, I get the following error:

org.alfresco.error.AlfrescoRuntimeException: 00030000 GetModelsDiff return status is 404

at org.alfresco.solr.client.SOLRAPIClient.getModelsDiff(SOLRAPIClient.java:1181).

 

Thanks.

Highlighted
Established Member II

Re: Change a model deploy in an amp by a jar

Jump to solution

As long as you don't make any changes to the deployed models it should work.

Did you change namespaces, type definitions or model names? 

Look carefully to the logs, because this error you showed may come from previous and more verbose errors. 

Highlighted
Active Member

Re: Change a model deploy in an amp by a jar

Jump to solution

Thanks Narkuss.

As Angel said it is necessary to has the same modele.id and module.version. By mistake I had a different letter in my module.id and it was provoking the "difference in the model".

 

Thank you very much.