content cannot be streamed to the client:This document can't be previewed

cancel
Showing results for 
Search instead for 
Did you mean: 
Member II

content cannot be streamed to the client:This document can't be previewed

Hi, I installed Alfresco 5.2 community edition on Google Cloud .

When we are try to open any .doc , docx files , Any MSOffice files its giving error that This document can't be previewed.

below is error from logs..

2018-02-26 17:15:14,160  ERROR [extensions.webscripts.AbstractRuntime] [http-apr-8080-exec-5] Exception from executeScript: 01260001 The content node was not specified so the content cannot be streamed to the client: classpath*:alfresco/templates/webscripts/org/alfresco/repository/thumbnail/thumbnail.get.js

 org.springframework.extensions.webscripts.WebScriptException: 01260001 The content node was not specified so the content cannot be streamed to the client: classpath*:alfresco/templates/webscripts/org/alfresco/repository/thumbnail/thumbnail.get.js

5 Replies
Professional

Re: content cannot be streamed to the client:This document can't be previewed

Is your soffice process running? Do all files fail to preview (even very small, simple ones) or just files of a certain size?

Active Member II

Re: content cannot be streamed to the client:This document can't be previewed

Hi - we are intermittently facing the same issue with some specific excel files. We are on Alfresco Community 5.2 on Ubuntu 16.04. I have tried the fixes from below post, but no luck:

Alfresco Notes: Transformation problems in Alfresco 5.0.d and Ubuntu 14.04 

and from this:

Troubleshooting Media Management | Alfresco Documentation 

Also tried turning off thumbnails.

This only happens on some excel files. Preview works fine for most excel files. File size doesn't seem to be the issue. It has failed for files as small as 100kb and as large as 8mb.

Any ideas?

Thanks.

Member II

Re: content cannot be streamed to the client:This document can't be previewed

I have the same problem, if my file size is more than 1 MB I have the issue like this,

2019-10-23 01:49:09,515 ERROR [extensions.webscripts.AbstractRuntime] [http-apr-8080-exec-6] Exception from executeScript: 09230002 The content node was not specified so the content cannot be streamed to the client: classpath*:alfresco/templates/webscripts/org/alfresco/repository/thumbnail/thumbnail.get.js
org.springframework.extensions.webscripts.WebScriptException: 09230002 The content node was not specified so the content cannot be streamed to the client: classpath*:alfresco/templates/webscripts/org/alfresco/repository/thumbnail/thumbnail.get.js

 

I also added this parameter in my alfresco-global.properties file. 

content.transformer.default.timeoutMs=64800000

 

still I have the issue. I have tried the docker image, tried the standalone installation. 

 

Now I have installed 5.2 community edition in CentOS 7. 

Any help or comment would be much appreciated. 

 

Thanks. 

 

Member II

Re: content cannot be streamed to the client:This document can't be previewed

Also wanted to check is this a limitation of community edition?

Saigop

Active Member II

Re: content cannot be streamed to the client:This document can't be previewed

Hi @jpotts, we have had the same issue in our environment for community 5.2 installed on a CentOS Linux release 7.0.1406 (Core) build. I set up a test system of community 6.2 on my windows 10 with a bitnami build and got the same error when trying to preview a document over 1MB. My fix for my test system was to add the following setting:

### Jod converter file size settings ###
content.transformer.JodConverter.extensions.docx.pdf.maxSourceSizeKBytes=10000

However, when I added this setting to our main environment on 5.2 it did not fix our issue.

The settings are quite different between the standard builds for both though:

These are the standard settings that were on my bitnami 6.2 install:

### External executable locations ###
ooo.exe=C:/ALFRES~1/LIBREO~1/App/libreoffice/program/soffice.exe
ooo.enabled=true
ooo.port=8100
img.root=C:\\Alfresco-201911-4\\imagemagick
img.coders=${img.root}/modules/coders
img.config=${img.root}/config
img.gslib=${img.root}\\lib
img.exe=${img.root}\\convert.exe
swf.exe=C:/ALFRES~1/swftools/pdf2swf.exe
swf.languagedir=C:/ALFRES~1/swftools/japanese
jodconverter.enabled=false
# JOD only for Alfresco Enterprise
jodconverter.officeHome=C:/ALFRES~1/LIBREO~1/App/libreoffice
jodconverter.portNumbers=8100

### Jod converter file size settings ###
content.transformer.JodConverter.extensions.docx.pdf.maxSourceSizeKBytes=10000

 

These are the settings that are in our live 5.2 properties file:

### External executable locations ###
ooo.exe=/var/www/html/alfresco-community/libreoffice/program/soffice.bin
ooo.enabled=true
ooo.port=8100
img.root=/var/www/html/alfresco-community/common
img.dyn=${img.root}/lib
img.exe=${img.root}/bin/convert

jodconverter.enabled=false
jodconverter.officeHome=/var/www/html/alfresco-community/libreoffice
jodconverter.portNumbers=8100

### Jod converter file size settings ###
content.transformer.JodConverter.extensions.docx.pdf.maxSourceSizeKBytes=10000

Do you have any idea what to change/add to our 5.2 community build for it to use the additional setting that works in my test system?