Custom content model doesn't show up in share

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
jeepers
Member II

Custom content model doesn't show up in share

Jump to solution

Good day everyone.

I'm trying to deploy a custom content model without using the GUI tool in administative tools. So far I understood the process as following:

1. Create an xml file which describes the model in /tomcat/shared/classes/alfresco/extension

2. Create an xml file with name mask *-context.xml in /tomcat/shared/classes/alfresco/extension to make a "spring bean"

3. Restart Alfresco

I've tried to rename the supplied exampleModel.xml.sample and example-model-context.xml.sample and restarted alfresco but custom model doesn't show up anywhere in Share.

Which steps am I missing?

BTW I'm using version Community - 5.2.0 (re21f2be5-b22)

1 Solution

Accepted Solutions
hardik1512
Established Member II

Re: Custom content model doesn't show up in share

Jump to solution

You need to configure Share to show custom types. Below link might be helpful

Share configuration for custom types and properties | Alfresco Documentation 

2 Replies
hardik1512
Established Member II

Re: Custom content model doesn't show up in share

Jump to solution

You need to configure Share to show custom types. Below link might be helpful

Share configuration for custom types and properties | Alfresco Documentation 

calvo
Senior Member

Re: Custom content model doesn't show up in share

Jump to solution

Hi,

You can modify "share-config-custom.xml" file.

Maybe this link could be useful (spanish):

NeTIC360: :: Alfresco. Creación de tipos de datos personalizados 

Regards,

clv