Custom Share advanced search does not work!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
sepgs2004
Active Member II

Custom Share advanced search does not work!

Jump to solution

I am following the steps mentioned in the following URL: Working With Custom Content Types in Alfresco

I customized Share tier. 

I have a custom type extending cm:content. This custom type has a mandatory custom aspect which has a set of custom properties.

Now, with the instructions in the online tutorial, I was able to bring my custom type in the Advanced search. Once I choose my custom type, the search form also brings all the custom aspect properties. 

Then when I search by the name of the document, I do not get any results. I know I have document matching the name.

However, if I look for "Content" type documents with the same name search field value, I get the results. 

The same does not work if I look for my custom type documents with the same name field value.

The documents that I have all belong to the custom type.

I do not know if the failure to find search results has anything to do with the checkbox fields. You know if we do not put any values in the checkbox fields, it may be considered no sometimes. Or it might have to do with some other types of fields and their default values.

I do not know if I missed any configuration.

1 Solution

Accepted Solutions
sepgs2004
Active Member II

Re: Custom Share advanced search does not work!

Jump to solution

Thank you for the reply.

I believe it has something to do with the initial values of the custom fields.

After few attempts, setting and un-setting values for the checkbox fields, my search started to work.

I could not guess anything else.

2 Replies
4535992
Established Member II

Re: Custom Share advanced search does not work!

Jump to solution

It's a bit old , but his link help me a lot, for a similar issue :

CounterSign/countersign-share-extension.xml at master · ntmcminn/CounterSign · GitHub 

i make it work on Alfresco 5.2 Community, with my own content model aspect.

sepgs2004
Active Member II

Re: Custom Share advanced search does not work!

Jump to solution

Thank you for the reply.

I believe it has something to do with the initial values of the custom fields.

After few attempts, setting and un-setting values for the checkbox fields, my search started to work.

I could not guess anything else.