Custom site creation not working in 201702

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
xarope
Member II

Custom site creation not working in 201702

Jump to solution

I've been using the custom site creation preset customization written up here: Think Alfresco: How to add custom Share site presets (the nice way) - Alfresco Hack #5 ).  Basically this was to customize the creation of several different types of collaboration sites, with different layouts and document library folders.  This worked in 4.2c up through to 5.0d.

A) Originally, I needed to customize the following files:

  1. /opt/alfresco/tomcat/webapps/share/WEB-INF/classes/alfresco/site-data/presets/presets.xml
  2. /opt/alfresco/tomcat/webapps/share/WEB-INF/classes/alfresco/site-webscripts/org/alfresco/modules/create-site.get.js
  3. /opt/alfresco/tomcat/webapps/share/WEB-INF/classes/alfresco/site-webscripts/org/alfresco/modules/create-site.get.properties
  4. and replaced the repository's "Populate Site with Folder from Template" script, found in Data Dictionary/Scripts (to customize the document library folders).

B) To prevent overwriting core files (and in case of upgrades in future), I ended up putting the files here instead:

  1. /opt/alfresco/tomcat/shared/classes/alfresco/web-extension/site-data/presets/presets.xml
  2. /opt/alfresco/tomcat/shared/classes/alfresco/web-extension/site-webscripts/org/alfresco/modules/create-site.get.js
  3. /opt/alfresco/tomcat/shared/classes/alfresco/web-extension/site-webscripts/org/alfresco/modules/create-site.get.properties

However, whilst testing the upgrade from 5.0d to 201702, I find that this no longer works; i.e. I used to be able to click "Create Site", and I would get the various customized sites, not just the standard Collaboration site. But now, I only get one choice, the default "Collaboration Site".

I tried method (B) first, then when this didn't work, I tried method (A).  Still no joy.

Has anybody else encountered this issue?  Has site creation changed in 201702 such that this no longer works?  And if so, does anybody have any suggestions on how to fix this?

1 Solution

Accepted Solutions
idwright
Senior Member

Re: Custom site creation not working in 201702

Jump to solution
3 Replies
idwright
Senior Member

Re: Custom site creation not working in 201702

Jump to solution
xarope
Member II

Re: Custom site creation not working in 201702

Jump to solution

That was it!   Enabled legacyMode and my old customizations are working again.

Thanks!

khadidja
Active Member

Re: Custom site creation not working in 201702

Jump to solution

Bonjour,

quand j'ai acceder je trouve la page vide : smileysad: