deploying with jar generated from alfresco sdk 3.0.1 getting error in alfresco 5.2

cancel
Showing results for 
Search instead for 
Did you mean: 
Active Member II

deploying with jar generated from alfresco sdk 3.0.1 getting error in alfresco 5.2

Hi,I have installed AC-5.2 with port 8090.

Getting error after deploying jars of repo and share in module in alfresco community 5.2 version.

After restarting alfresco server showing error like: 

2018-01-05 15:41:59,530 INFO [webscripts.connector.RemoteClient] [http-apr-8090-exec-3] Exception calling (GET) http://localhost:8080/alfresco/s/api/admin/restrictions?guest=true
2018-01-05 15:41:59,534 INFO [webscripts.connector.RemoteClient] [http-apr-8090-exec-3] Error status 503 Connect to localhost:8080 [localhost/127.0.0.1, localhost/0:0:0:0:0:0:0:1] failed: Connection refused: connect
org.apache.http.conn.HttpHostConnectException: Connect to localhost:8080 [localhost/127.0.0.1, localhost/0:0:0:0:0:0:0:1] failed: Connection refused: connect

But my port is 8090 in AC-5.2 and not able to login. I using sdk 3.0.1 for doing build.Please find the attachment for logs.

5 Replies
Senior Member II

Re: deploying with jar generated from alfresco sdk 3.0.1 getting error in alfresco 5.2

Please check your jar file for the share.

When you generate a share jar, It includes the share-config-custom.xml. By default  this file contains the configuration, for port 8080 for connecting to repository server.

You have 2 options for resolution.

Either change the configuration in share jar file or change the port configuration in server.

Change the configuration in share jar file is the best thing to do.

Active Member II

Re: deploying with jar generated from alfresco sdk 3.0.1 getting error in alfresco 5.2

Hi Krutik,

In share-config-custom.xml file doesn't contain's 8080 port in it.I had checked it before deploying also.

Active Member

Re: deploying with jar generated from alfresco sdk 3.0.1 getting error in alfresco 5.2

Hi Kumar, What was the resolution assuming you managed to resolve?

Active Member II

Re: deploying with jar generated from alfresco sdk 3.0.1 getting error in alfresco 5.2

Hi gregwright78 _ ,

I didn't resolved it till causing same problem. if add those jars in 9090 ports alfresco installed. I checked in share config files even that file is not contains 8081 then also it trying to redirect to 8081.

Active Member

Re: deploying with jar generated from alfresco sdk 3.0.1 getting error in alfresco 5.2

OK thanks for the reply. I'm getting issues running integration tests (similar error occuring for existing unit test classes) for which I'm trying to migrate an existing Alfresco project from using the Alfresco 2.2 to Alfresco SDK 3.0.1. I'll let you know if I find anything that may help you though.