Deployment of the HelloWord buid with SDK 3 to Alfresco 4.2

cancel
Showing results for 
Search instead for 
Did you mean: 
vmiorga
Active Member II

Deployment of the HelloWord buid with SDK 3 to Alfresco 4.2

Jump to solution

Hello,

I actually try do deploy an HelloWorld project on alfresco 4.2, and I am stuck.

What I have done:

Now I am here. I see different error in the console, and I didn't succeed to debug them. I am asking myself if all those errors are relevant to my situation.

Here is the list of what I meet:

1)

GRAVE: Failed to initialize end point associated with ProtocolHandler ["http-bio-8080"]
java.net.BindException: Address already in use: JVM_Bind <null>:8080

...

Caused by: java.net.BindException: Address already in use: JVM_Bind

...

I have actually only the tomcat of alfressco which he running on my computer, so I don't see why the port 8080 is already in use?

2)

2017-08-24 15:25:20,000  ERROR [web.context.ContextLoader] [localhost-startStop-1] Context initialization failed
 org.alfresco.error.AlfrescoRuntimeException: 07240008 Failed to start modules

....

org.alfresco.repo.management.SafeApplicationEventMulticaster.multicastEventInternal(SafeApplicationEventMulticaster.java:209)

...
Caused by: org.alfresco.error.AlfrescoRuntimeException: 07240007 The module properties file 'file [C:\Projet\hellow3\target\tomcat\webapps\hellow3-platform\WEB-INF\classes\alfresco\module\hellow3\module.properties]' could not be read.
 ...

Caused by: org.alfresco.error.AlfrescoRuntimeException: 07240006 The version string '1.0-SNAPSHOT' is invalid.

1.0-SNAPSHOT, is the version of my project, I didn't change it from the creation with the archetype

3)

GRAVE: The web application [/alfresco] appears to have started a thread named [H2 TCP Server (tcp://192.168.2.98:65460)] but has failed to stop it. This is very likely to create a memory leak.
août 24, 2017 3:53:53 PM org.apache.catalina.loader.WebappClassLoader clearReferencesThreads

GRAVE: The web application [/alfresco] appears to have started a thread named [MVStore background writer nio:C:/Projet/hellow3/alf_data_dev/h2_data/alf_dev.mv.db] but has failed to stop it. This is very likely to create a memory leak.
août 24, 2017 3:53:53 PM org.apache.catalina.loader.WebappClassLoader clearReferencesThreads

GRAVE: The web application [/alfresco] appears to have started a thread named [DefaultScheduler_Worker-1] but has failed to stop it. This is very likely to create a memory leak.
août 24, 2017 3:53:53 PM org.apache.catalina.loader.WebappClassLoader clearReferencesThreads

I put this "-Xms512m -Xmx2G -XXSmiley TongueermSize=300m" as param for the JVM, this is not enough?

4)

 2017-08-24 15:26:00,858  ERROR [solr.tracker.CoreTracker] [SolrTrackerScheduler_Worker-3] Tracking failed
 org.alfresco.error.AlfrescoRuntimeException: 07240001 GetModelsDiff return status is 302

I have no idea for this.

Thanks.

VM

1 Solution

Accepted Solutions
kalpesh_c2
Senior Member

Re: Deployment of the HelloWord buid with SDK 3 to Alfresco 4.2

Jump to solution

Hi, V M
The default port used by alfresco is 8080,
default port used by SDK for repository it's 8080 and for share it's 8081
I think you may have started both alfresco and SDK so for that you are getting the error 
Caused by: java.net.BindException: Address already in use: JVM_Bind
Or port 8080 may be occupied by other process in your system

if you want to run both then you have to change the Alfresco Repo SDK Default port
To change the SDK default port change remote tag in Share SDK's share-config-custom.xml file

path your-project\src\main\resources\META-INF\share-config-custom.xml

<config evaluator="string-compare" condition="Remote">
<remote>
<endpoint>
<id>alfresco-noauth</id>
<name>Alfresco - unauthenticated access</name>
<description>Access to Alfresco Repository WebScripts that do not require authentication</description>
<connector-id>alfresco</connector-id>
<endpoint-url>http://localhost:8092/alfresco/s</endpoint-url>
<identity>none</identity>
</endpoint>
<endpoint>
<id>alfresco</id>
<name>Alfresco - user access</name>
<description>Access to Alfresco Repository WebScripts that require user authentication</description>
<connector-id>alfresco</connector-id>
<endpoint-url>http://localhost:8092/alfresco/s</endpoint-url>
<identity>user</identity>
</endpoint>
<endpoint>
<id>alfresco-feed</id>
<name>Alfresco Feed</name>
<description>Alfresco Feed - supports basic HTTP authentication via the EndPointProxyServlet</description>
<connector-id>http</connector-id>
<endpoint-url>http://localhost:8092/alfresco/s</endpoint-url>
<basic-auth>true</basic-auth>
<identity>user</identity>
</endpoint>

<endpoint>
<id>alfresco-api</id>
<parent-id>alfresco</parent-id>
<name>Alfresco Public API - user access</name>
<description>Access to Alfresco Repository Public API that require user authentication.
This makes use of the authentication that is provided by parent 'alfresco' endpoint.</description>
<connector-id>alfresco</connector-id>
<endpoint-url>http://localhost:8092/alfresco/api</endpoint-url>
<identity>user</identity>
</endpoint>
</remote>
</config>‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍

And change in pom.xml of Repo SDK your-project\pom.xml

<properties>
        <maven.tomcat.port>8092</maven.tomcat.port>
</properties>‍‍‍

 


Thanks,
Kalpesh

ContCentric

3 Replies
kalpesh_c2
Senior Member

Re: Deployment of the HelloWord buid with SDK 3 to Alfresco 4.2

Jump to solution

Hi, V M
The default port used by alfresco is 8080,
default port used by SDK for repository it's 8080 and for share it's 8081
I think you may have started both alfresco and SDK so for that you are getting the error 
Caused by: java.net.BindException: Address already in use: JVM_Bind
Or port 8080 may be occupied by other process in your system

if you want to run both then you have to change the Alfresco Repo SDK Default port
To change the SDK default port change remote tag in Share SDK's share-config-custom.xml file

path your-project\src\main\resources\META-INF\share-config-custom.xml

<config evaluator="string-compare" condition="Remote">
<remote>
<endpoint>
<id>alfresco-noauth</id>
<name>Alfresco - unauthenticated access</name>
<description>Access to Alfresco Repository WebScripts that do not require authentication</description>
<connector-id>alfresco</connector-id>
<endpoint-url>http://localhost:8092/alfresco/s</endpoint-url>
<identity>none</identity>
</endpoint>
<endpoint>
<id>alfresco</id>
<name>Alfresco - user access</name>
<description>Access to Alfresco Repository WebScripts that require user authentication</description>
<connector-id>alfresco</connector-id>
<endpoint-url>http://localhost:8092/alfresco/s</endpoint-url>
<identity>user</identity>
</endpoint>
<endpoint>
<id>alfresco-feed</id>
<name>Alfresco Feed</name>
<description>Alfresco Feed - supports basic HTTP authentication via the EndPointProxyServlet</description>
<connector-id>http</connector-id>
<endpoint-url>http://localhost:8092/alfresco/s</endpoint-url>
<basic-auth>true</basic-auth>
<identity>user</identity>
</endpoint>

<endpoint>
<id>alfresco-api</id>
<parent-id>alfresco</parent-id>
<name>Alfresco Public API - user access</name>
<description>Access to Alfresco Repository Public API that require user authentication.
This makes use of the authentication that is provided by parent 'alfresco' endpoint.</description>
<connector-id>alfresco</connector-id>
<endpoint-url>http://localhost:8092/alfresco/api</endpoint-url>
<identity>user</identity>
</endpoint>
</remote>
</config>‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍

And change in pom.xml of Repo SDK your-project\pom.xml

<properties>
        <maven.tomcat.port>8092</maven.tomcat.port>
</properties>‍‍‍

 


Thanks,
Kalpesh

ContCentric

vmiorga
Active Member II

Re: Deployment of the HelloWord buid with SDK 3 to Alfresco 4.2

Jump to solution

Hi, Kalpesh Patel

Your proposition solve the first issues, thank.

And I see a change concerning the fourth issue, the message is now:

2017-09-11 13:52:00,049  ERROR [solr.tracker.CoreTracker] [SolrTrackerScheduler_Worker-1] Tracking failed
 org.alfresco.error.AlfrescoRuntimeException: 08110044 GetModelsDiff return status is 404

I will continue to investigate.

vmiorga
Active Member II

Re: Deployment of the HelloWord buid with SDK 3 to Alfresco 4.2

Jump to solution

The problem was that I didn't understand that the SDK start his own alfresco instance and deploy the jar on this instance. Initially I was expecting that the artefact was deploy on the alfresco I had install on my computer.