Developpement for Alfresco 4.2

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Active Member II

Developpement for Alfresco 4.2

Jump to solution

Hello I have to develop a project for Alfresco 4.2, if I had correctly understood the documentation I have to use the SDK 1.1.0 for the development.

I used this documentation: Maven Alfresco SDK Quick Start | Alfresco Documentation 

but when I call the maven archetype I get :

[ERROR] Failed to execute goal org.apache.maven.plugins:maven-archetype-plugin:3.0.1:generate (default-cli) on project standalone-pom: archetypeCatalog 'https://artifacts.alfresco.com/nexus/content/groups/public/archetype-catalog.xml' is not supported anymore.

For the moment the only HelloWorld project I successfully compile use the SDK 2.2 (by using the doc receive by mail), and when I tried to change in the pom.xml the sdk version I get:

Project build error: Non-resolvable parent POM for com.vian:test-repo:1.0-SNAPSHOT: Failure to find org.alfresco.maven:alfresco-sdk-parentSmiley Tongueom:1.1.0 in https://repo.maven.apache.org/maven2 was cached in the local repository, resolution will not be reattempted until the update interval of central has elapsed or updates are forced and 'parent.relativePath' points at wrong local POM

Does still possible to develop for Alfresco 4.2 ?

best regard

1 Solution

Accepted Solutions
Highlighted
Alfresco Employee

Re: Developpement for Alfresco 4.2

Jump to solution

No problem, I'm happy to point you on the right documentation.

Alfresco SDK 3.0 | Alfresco Documentation 

I suggest you to dive into the links structure.

There is a lot of content there.

All valid also for Alfresco Content Services Community Edition 4.2.f.

Cheers.

View solution in original post

6 Replies
Highlighted
Alfresco Employee

Re: Developpement for Alfresco 4.2

Jump to solution

Hi,

Are you using Community Edition or Enterprise Edition?

Which Alfresco version are you planning to use?

If you plan to use the Alfresco Community Edition 4.2.f you can use SDK 3.0.1.

It is strongly suggested. ;-)

I hope it helps you.

Highlighted
Active Member II

Re: Developpement for Alfresco 4.2

Jump to solution

Hello,

I have to develop for the Community Edition 4.2.f. It is the first time I read that the SDK 3.X exist.

I only find this page as information: RAD! Alfresco SDK 3.0. Upgrade and enjoy! – Swazzy 

By change did you have a link to a tuto how create and deploy a project with the SDK 3.0.1?

Highlighted
Alfresco Employee

Re: Developpement for Alfresco 4.2

Jump to solution

No problem, I'm happy to point you on the right documentation.

Alfresco SDK 3.0 | Alfresco Documentation 

I suggest you to dive into the links structure.

There is a lot of content there.

All valid also for Alfresco Content Services Community Edition 4.2.f.

Cheers.

View solution in original post

Highlighted
Advanced II

Re: Developpement for Alfresco 4.2

Jump to solution

The exact documentation you need for 4.2 is available here Switch to using Alfresco version 4.2.x | Alfresco Documentation 

I tried it today with an old project using Alfresco 4.2.f and it worked really well.

Highlighted
Active Member II

Re: Developpement for Alfresco 4.2

Jump to solution

Yes, the initial issue was that I used the documentation of Alfresco 4.2 (Alfresco One 4.2.7 | Alfresco Documentation ) which is not up to date. It could be good to put a link/information saying that the SDK 1.1 is not more provided and that the SDK 3.X is to be used, which documentation is in the documentation of Alfresco Community Edition 201707

and more specialy in the both link up.

Highlighted
Alfresco Employee

Re: Developpement for Alfresco 4.2

Jump to solution

Thank you for the suggestion.
Including Helen Mullally, leading the Documentation Website (and Team), to submit it to her attention.

Cheers.