Did you try https://github.com/Alfresco/alfresco-docker-installer? Yes, I did!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Active Member

Did you try https://github.com/Alfresco/alfresco-docker-installer? Yes, I did!

Jump to solution

https://github.com/Alfresco/alfresco-docker-installer

I have tried 6.1 and 6.2

readme says login/password is admin/admin

but when I tries login to alfresco.domain.local/ or alfresco.domain.local/share/  I get a login error:

alfresco61.png

 

alfrescoshare61.png

1 Solution

Accepted Solutions
Highlighted
Alfresco Employee

Re: Did you try https://github.com/Alfresco/alfresco-docker-installer? Yes, I did!

Jump to solution
4 Replies
Highlighted
Alfresco Employee

Re: Did you try https://github.com/Alfresco/alfresco-docker-installer? Yes, I did!

Jump to solution

Are you using Windows as host for Docker?

Can you inspect the log files of the Docker Containers to check if every service is up and running?

Software Engineer in Alfresco Search Team.
Highlighted
Active Member

Re: Did you try https://github.com/Alfresco/alfresco-docker-installer? Yes, I did!

Jump to solution

Docker hosted at Debian 10 VM at Proxmox

seems like something with Postgres container, something with permissions

docker-compose ps
Name Command State Ports
-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
docker-compose_activemq_1 /bin/sh -c ${ACTIVEMQ_HOME ... Up 0.0.0.0:5672->5672/tcp, 0.0.0.0:61613->61613/tcp, 0.0.0.0:61616->61616/tcp, 0.0.0.0:8161->8161/tcp
docker-compose_alfresco-pdf-renderer_1 /bin/sh -c java $JAVA_OPTS ... Up 0.0.0.0:8090->8090/tcp
docker-compose_alfresco_1 catalina.sh run -security Up 8080/tcp
docker-compose_content-app_1 /entrypoint.sh Up 80/tcp, 8080/tcp
docker-compose_imagemagick_1 /bin/sh -c java $JAVA_OPTS ... Up 0.0.0.0:8091->8090/tcp
docker-compose_libreoffice_1 /bin/sh -c java $JAVA_OPTS ... Up 0.0.0.0:8092->8090/tcp
docker-compose_postgres_1 docker-entrypoint.sh postg ... Exit 1
docker-compose_proxy_1 nginx -g daemon off; Up 0.0.0.0:443->443/tcp, 80/tcp
docker-compose_share_1 /usr/local/tomcat/shared/c ... Up 8000/tcp, 8080/tcp
docker-compose_solr6_1 /bin/sh -c $DIST_DIR/solr/ ... Up 8983/tcp
docker-compose_tika_1 /bin/sh -c java $JAVA_OPTS ... Up 0.0.0.0:8093->8090/tcp
docker-compose_transform-misc_1 /bin/sh -c java $JAVA_OPTS ... Up 0.0.0.0:8094->8090/tcp
docker logs docker-compose_postgres_1
The files belonging to this database system will be owned by user "postgres".
This user must also own the server process.

The database cluster will be initialized with locale "en_US.utf8".
The default database encoding has accordingly been set to "UTF8".
The default text search configuration will be set to "english".

Data page checksums are disabled.

fixing permissions on existing directory /var/lib/postgresql/data ... ok
creating subdirectories ... ok
selecting default max_connections ... 100
selecting default shared_buffers ... 128MB
selecting default timezone ... Etc/UTC
selecting dynamic shared memory implementation ... posix
creating configuration files ... ok
running bootstrap script ... ok
performing post-bootstrap initialization ... ok

WARNING: enabling "trust" authentication for local connections
You can change this by editing pg_hba.conf or using the option -A, or
--auth-local and --auth-host, the next time you run initdb.
syncing data to disk ... ok

Success. You can now start the database server using:

pg_ctl -D /var/lib/postgresql/data -l logfile start

waiting for server to start....2020-06-22 15:07:47.024 UTC [42] LOG: listening on Unix socket "/var/run/postgresql/.s.PGSQL.5432"
2020-06-22 15:07:47.397 UTC [43] LOG: database system was shut down at 2020-06-22 15:07:45 UTC
2020-06-22 15:07:47.467 UTC [42] LOG: database system is ready to accept connections
done
server started
CREATE DATABASE


/usr/local/bin/docker-entrypoint.sh: ignoring /docker-entrypoint-initdb.d/*

2020-06-22 15:07:48.921 UTC [42] LOG: received fast shutdown request
waiting for server to shut down....2020-06-22 15:07:48.959 UTC [42] LOG: aborting any active transactions
2020-06-22 15:07:48.962 UTC [42] LOG: background worker "logical replication launcher" (PID 49) exited with exit code 1
2020-06-22 15:07:48.962 UTC [44] LOG: shutting down
2020-06-22 15:07:49.093 UTC [42] LOG: database system is shut down
done
server stopped

PostgreSQL init process complete; ready for start up.

2020-06-22 15:07:49.196 UTC [1] LOG: listening on IPv4 address "0.0.0.0", port 5432
2020-06-22 15:07:49.196 UTC [1] LOG: listening on IPv6 address "::", port 5432
2020-06-22 15:07:49.243 UTC [1] LOG: listening on Unix socket "/var/run/postgresql/.s.PGSQL.5432"
2020-06-22 15:07:49.312 UTC [1] FATAL: could not open log file "/var/log/postgresql/postgresql-2020-06-22_150749.log": Permission denied
2020-06-22 15:07:49.328 UTC [1] LOG: database system is shut down
Highlighted
Alfresco Employee

Re: Did you try https://github.com/Alfresco/alfresco-docker-installer? Yes, I did!

Jump to solution
Highlighted
Active Member

Re: Did you try https://github.com/Alfresco/alfresco-docker-installer? Yes, I did!

Jump to solution

ok thanks!

now it works