Different file upload behavior for WebDAV and AOS

cancel
Showing results for 
Search instead for 
Did you mean: 
Member II

Different file upload behavior for WebDAV and AOS

I'm experiencing different behaviors from the WebDAV and AOS protocols when trying to upload a file to Alfresco Community 6.1.2 (having the alfresco-aos-module-1.2.2.amp and the _vti_bin.war installed). When uploading a file using the HTTP PUT verb everything works fine in the WebDAV case:

$ curl -i -u admin:admin -T '/path/to/file/test.txt' "http://repo1:8080/alfresco/webdav/Sites/swsdp/documentLibrary/test.txt"
HTTP/1.1 100

HTTP/1.1 201
Set-Cookie: JSESSIONID=DC856FA6BB3E1D33CA91C72A6B21FD50; Path=/alfresco; HttpOnly
Content-Length: 0
Date: Thu, 09 May 2019 07:43:11 GMT

But when I do the same request in the AOS case

$ curl -i -u admin:admin -T '/path/to/file/test.txt' "http://repo1:8080/alfresco/aos/Sites/swsdp/documentLibrary/test2.txt"
HTTP/1.1 100

HTTP/1.1 201
MicrosoftSharePointTeamServices: 15.0.0.4420
Set-Cookie: JSESSIONID=858347E93D94B60CF691E87E8515FA91; Path=/alfresco; HttpOnly
MS-Author-Via: MS-FP/4.0,DAV
MicrosoftOfficeWebServer: 5.0_Collab
DocumentManagementServer: Properties Schema;Source Control;Version History;
DAV: 1,2
Allow: GET, POST, OPTIONS, HEAD, MKCOL, PUT, PROPFIND, PROPPATCH, DELETE, MOVE, COPY, GETLIB, LOCK, UNLOCK
Accept-Ranges: none
Cache-Control: no-cache
Last-Modified: Thu, 09 May 2019 07:46:02 GMT
ETag: "{FE671785-D825-4699-B9E6-4984E8D3C139},-1685166175"
ResourceTag: rt:{FE671785-D825-4699-B9E6-4984E8D3C139}@00001000000
Content-Length: 0
Date: Thu, 09 May 2019 07:46:02 GMT

The HTTP status code looks fine (201), and the file is actually created in the document library, but there is no content in the file (i.e. its size is marked as 0 bytes) and the following error is seen in the logs:

2019-05-09 09:46:02,074  ERROR [aosmodule.vfs.DocumentNode] [http-nio-8080-exec-6] Error writing content.
 org.alfresco.service.cmr.repository.InvalidNodeRefException: Node does not exist: workspace://SpacesStore/fe671785-d825-4699-b9e6-4984e8d3c139 (status:null)
        at org.alfresco.repo.node.db.DbNodeServiceImpl.getNodePairNotNull(DbNodeServiceImpl.java:187)
        at org.alfresco.repo.node.db.DbNodeServiceImpl.hasAspect_aroundBody38(DbNodeServiceImpl.java:1015)
        at org.alfresco.repo.node.db.DbNodeServiceImpl$AjcClosure39.run(DbNodeServiceImpl.java:1)

...

Any idea on what the problem could be?

(other requests (MKCOL, GET, DELETE) work fine in both the WebDAV and AOS case)