docker-compose up Error

cancel
Showing results for 
Search instead for 
Did you mean: 
ahmedredamoha
Member II

docker-compose up Error

I get the following error when typing in

cmd >docker-compose up

ERROR: client version 1.22 is too old. Minimum supported API version is 1.24, please upgrade your client to a newer version

7 Replies
janv
Senior Member II

Re: docker-compose up Error

In addition to "docker version", you also need to check:

$ docker-compose version

Regards,

Jan

ahmedredamoha
Member II

Re: docker-compose up  Error

>docker-compose version
docker-compose version 1.24.0, build 0aa59064
docker-py version: 3.7.2
CPython version: 3.6.8
OpenSSL version: OpenSSL 1.0.2q 20 Nov 2018

janv
Senior Member II

Re: docker-compose up  Error

Hmm, odd. 

I use MacOS but could try in a Windows 10 VM .... unless anyone else has seen the same issue ?

ahmedredamoha
Member II

Re: docker-compose up  Error

Many thanks Jan for support .

janv
Senior Member II

Re: docker-compose up Error

No worries. Please try to avoid cross-posting. I suggest we continue the conversation here:

https://community.alfresco.com/message/845485-alfresco-digital-workspace-login-issue

bima
Member II

Re: docker-compose up  Error

docker-compose version
docker-compose version 1.25.0, build 0a186604
docker-py version: 4.1.0
CPython version: 3.7.5
OpenSSL version: OpenSSL 1.1.1d 10 Sep 2019

 

Still got this error, how can i solve it?

pls advice

narkuss
Active Member II

Re: docker-compose up  Error

What is the version in the docker-compose file?

How did you install docker for windows? Did you install Docker Desktop I assume?