Docker edition Al fresco install problem

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
deepakdeshp
Member II

Docker edition Al fresco install problem

Jump to solution

Hello,

I am trying to install Docker Alfresco but am getting error. The link I am following is

ALF docker install process  . I am using 64 bit Ubuntu server 18.04 which is fully updated.

git clone https://github.com/Alfresco/acs-community-deployment.git
Cloning into 'acs-community-deployment'...
fatal: unable to access 'https://github.com/Alfresco/acs-community-deployment.git/': server certificate verification failed. CAfile: /etc/ssl/certs/ca-certificates.crt CRLfile: none

Please suggest

1 Solution

Accepted Solutions
fedorow
Established Member II

Re: Docker edition Al fresco install problem

Jump to solution

Alfresco docker-compose deployment minimum memory requirement is 12GB. It can starts on 8GB, but without any others application. 

You use VM with 4GB memory. So try to start it directly on your 8Gb mint or take bigge vm.

View solution in original post

15 Replies
fedorow
Established Member II

Re: Docker edition Al fresco install problem

Jump to solution
  1. install docker
  2. install docker-compose
  3. download yaml file
  4. run docker-compose

Commands to do so on ubuntu 18.04 is bellow:

sudo apt-get update
sudo apt-get install \
apt-transport-https \
ca-certificates \
curl \
gnupg-agent \
software-properties-common
curl -fsSL https://download.docker.com/linux/ubuntu/gpg | sudo apt-key add -
sudo apt-key fingerprint 0EBFCD88
sudo add-apt-repository \
"deb [arch=amd64] https://download.docker.com/linux/ubuntu \
$(lsb_release -cs) \
stable"
sudo apt-get update
sudo apt-get install docker-ce docker-ce-cli containerd.io
sudo curl -L "https://github.com/docker/compose/releases/download/1.24.0/docker-compose-$(uname -s)-$(uname -m)" -o /usr/local/bin/docker-compose
sudo chmod +x /usr/local/bin/docker-compose

sudo wget https://github.com/Alfresco/acs-community-deployment/blob/master/docker-compose/docker-compose.yml 

sudo docker-compose up

deepakdeshp
Member II

Re: Docker edition Al fresco install problem

Jump to solution

Thank you.

The following error I am getting.

sudo add-apt-repository "deb [arch=amd64] https://download.docker.com/linux/ubuntu\
$(lsb_release -cs) \
stable"
E: Malformed entry 65 in list file /etc/apt/sources.list (Component)
E: The list of sources could not be read.

65th line in  /etc/apt/sources.list is

deb [arch=amd64] https://download.docker.com/linux/ubuntubionic stable

Please suggest.

deepakdeshp
Member II

Re: Docker edition Al fresco install problem

Jump to solution

I changed the line 65 in and was able to go to the next step. But I had further errors.

sudo apt-get install docker-ce docker-ce-cli containerd.io
Reading package lists... Done
Building dependency tree
Reading state information... Done
containerd.io is already the newest version (1.2.5-1).
docker-ce-cli is already the newest version (5:18.09.5~3-0~ubuntu-bionic).
docker-ce is already the newest version (5:18.09.5~3-0~ubuntu-bionic).
uma@mail:~$ sudo curl -L "https://github.com/docker/compose/releases/download/1.24.0/docker-compose-$(uname-s)-$(uname -m)" -o /usr/local/bin/docker-compose
uname-s: command not found
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
0 0 0 0 0 0 0 0 --:--:-- 0:00:05 --:--:-- 0
curl: (60) SSL certificate problem: unable to get local issuer certificate
More details here: https://curl.haxx.se/docs/sslcerts.html

curl failed to verify the legitimacy of the server and therefore could not
establish a secure connection to it. To learn more about this situation and
how to fix it, please visit the web page mentioned above.
uma@mail:~$ sudo chmod +x /usr/local/bin/docker-compose^C
uma@mail:~$ sudo curl -L "https://github.com/docker/compose/releases/download/1.24.0/docker-compose-(uname-s)-(uname -m)" -o /usr/local/bin/docker-compose
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
0 0 0 0 0 0 0 0 --:--:-- 0:00:15 --:--:-- 0
curl: (60) SSL certificate problem: unable to get local issuer certificate
More details here: https://curl.haxx.se/docs/sslcerts.html

curl failed to verify the legitimacy of the server and therefore could not
establish a secure connection to it. To learn more about this situation and
how to fix it, please visit the web page mentioned above.
uma@mail:~$ -s)-$(uname -m)" -o /usr/local/bin/docker-compose
-bash: syntax error near unexpected token `)'
uma@mail:~$ sudo chmod +x /usr/local/bin/docker-compose
uma@mail:~$ sudo wget https://github.com/Alfresco/acs-community-deployment/blob/master/docker-compose/docker-compose.ym
--2019-08-18 03:29:04-- https://github.com/Alfresco/acs-community-deployment/blob/master/docker-compose/docker-compose.ym
Resolving github.com (github.com)... 198.44.252.107
Connecting to github.com (github.com)|198.44.252.107|:443... connected.
ERROR: cannot verify github.com's certificate, issued by ‘CN=localhost,OU=dev,O=vihoo’:
Unable to locally verify the issuer's authority.
ERROR: no certificate subject alternative name matches
requested host name ‘github.com’.
To connect to github.com insecurely, use `--no-check-certificate'.
uma@mail:~$ sudo docker-compose up
ERROR: yaml.scanner.ScannerError: mapping values are not allowed here
in "./docker-compose.yml", line 605, column 26

fedorow
Established Member II

Re: Docker edition Al fresco install problem

Jump to solution

I think you should read official docker documentation, and give an attention to test and troubleshooting tips.

  1. Detailed instructions of  docker installation you can read at Get Docker Engine - Community for Ubuntu | Docker Documentation.
  2. To install docker-compose https://docs.docker.com/compose/install/
  3. To solve github.com certificate problem try

sudo update-ca-certificates -f

sudo wget https://github.com/Alfresco/acs-community-deployment/blob/master/docker-compose/docker-compose.yml

or

sudo wget --no-check-certificate https://github.com/Alfresco/acs-community-deployment/blob/master/docker-compose/docker-compose.yml

4. Run application

sudo docker-compose up

deepakdeshp
Member II

Re: Docker edition Al fresco install problem

Jump to solution

Thank you.

Docker composer and docker are installed but the yml file gives error.

 docker --version
Docker version 18.09.5, build e8ff056
uma@mail:~$ docker-compose --version
docker-compose version 1.24.0, build 0aa59064
uma@mail:~$ docker-compose up
ERROR: yaml.scanner.ScannerError: mapping values are not allowed here
in "./docker-compose.yml", line 605, column 26

The line 605 of docker-compose.yml is 

<!-- blob contrib key: blob_contributors:v21:ff5b43c769233d39bb900b22199b2eef -->

fedorow
Established Member II

Re: Docker edition Al fresco install problem

Jump to solution

sudo...

deepakdeshp
Member II

Re: Docker edition Al fresco install problem

Jump to solution

Even with sudo same problem.

sudo docker-compose up
[sudo] password for uma:
ERROR: yaml.scanner.ScannerError: mapping values are not allowed here
in "./docker-compose.yml", line 605, column 26

fedorow
Established Member II

Re: Docker edition Al fresco install problem

Jump to solution

Sorry, wrong url in wget command.

Go to your work directory. Remove bad file docker-compose.yml

sudo rm docker-compose.yml

And download it again

sudo wget --no-check-certificate --content-disposition https://raw.githubusercontent.com/Alfresco/acs-community-deployment/master/docker-compose/docker-com...

sudo docker-compose up

deepakdeshp
Member II

Re: Docker edition Al fresco install problem

Jump to solution

Thank you. It is pulling from the repository now. The yml file is correct.

After all the software is pulled will the command sudo docker-compose up

will it pull software again each time I give sudo docker-compose up?