Docker Swarm

cancel
Showing results for 
Search instead for 
Did you mean: 
Customer

Docker Swarm

Looking to see if anyone has any experience deploy Alfresco 6.2 in Swarm on AWS.  If so can you share you docker-compose setup for this. We are starting out with the Alfresco sample docker-compose.yaml but it is not production ready.

Thanks,

Rich

 

3 Replies
Community Manager
Community Manager

Re: Docker Swarm

Hi @rstoops,

Could I ask what your use case for using Swarm is please? I ask because it's not something we see very often.

There is an old discussion that mentions using Swarm and this Kubernetes Activiti 7 guide but not a lot more.

HTH

Digital Community Manager, Alfresco Software.
Problem solved? Click Accept as Solution!
Customer

Re: Docker Swarm

My company has decided that our first AWS deploy of Alfresco 6.x is going to be done in Swarm since we are not ready for K8 as of yet.

We are using the docker-compose.yaml supplied by Alfresco as a starting point and tweaking it from there.  Unfortuantely, we don't have any expertise in either Swarm or K8.

 

Moderator
Moderator

Re: Docker Swarm

The docker-compose.yml you get still on docker-compose version 2 which is not supported for swarm as far as i know. To use swarm, docker-compose.yml needs to be configured on version 3.x.

this docker-compose.yml has mem_limit configuration for several services, which is also not supported in docker compose version 3.x and needs to be replaced with deploy.resources config. All these gaps indicates that the docker-compose.yml supplied by alfresco is not swarm ready. But can be worked to make it compatible for swarm.

 

Something like:

version: "3.8"

services:
    alfresco:
        image: alfresco/alfresco-content-repository:6.2.1
        deploy:
          resources:
            limits:
              memory: 1700m

Docker has provided a "--compatibility" mode option for docker-compose in order to use v3.x docker-compose.yml without swarm while working on dev activities, it is not recommended for production. You will get a warning when try to use v3.x docker-compose.yml to launch containers without swarm.

 

To silent the warning, following command can be used, if testing without swarm:

 

docker-compose -f ./docker-compose.yml --compatibility up

or -- if there are custom build configurations defined in docker-compose.

docker-compose -f ./docker-compose.yml --compatibility up --build

 

Once you changed the docker-compose.yml to v3, it will be ready for swarm

 

~Abhinav
(ACSCE, AWS SAA-C02, GAIQ)