Edit online still not working

cancel
Showing results for 
Search instead for 
Did you mean: 
kamilaw_
Member II

Edit online still not working

Jump to solution

Online Edit action opens an empty Word. Form requiring a credential does not appear.

I solved this problem for Alfresco 5.0.d. The solution was: in regedit change BaseAuth value and in Chrome install plugin.

But now I have Alfresco 5.2 and 5.1 and this solution does not work for these versions.

Is there some official solution of this well known problem? (There are a lot of comments of this, but I do not know what is the correct one.)

1 Solution

Accepted Solutions
mehe
Senior Member II

Re: Edit online still not working

Jump to solution

Hi,

As I understand you are using alfresco community 5.1 and 5.2 without ssl, have configured basicAuth in the hklm and hcu office like described in https://support.microsoft.com/en-us/help/2123563/office-application-opens-blank-from-sharepoint,webd... 

according to your office and Windows Version.

Your alfresco-global.properties has the alfresco and share context/host/port/protocol configured for your alfresco server.

And: do not forget the repository url in share-config-custom.xml

<repository-url>http://yourserver:port/alfresco</repository-url>‍‍

use chrome or Firefox developer tools to see what URL is generated for opening the office file - maybe there is something wrong.

3 Replies
mehe
Senior Member II

Re: Edit online still not working

Jump to solution

Hi,

As I understand you are using alfresco community 5.1 and 5.2 without ssl, have configured basicAuth in the hklm and hcu office like described in https://support.microsoft.com/en-us/help/2123563/office-application-opens-blank-from-sharepoint,webd... 

according to your office and Windows Version.

Your alfresco-global.properties has the alfresco and share context/host/port/protocol configured for your alfresco server.

And: do not forget the repository url in share-config-custom.xml

<repository-url>http://yourserver:port/alfresco</repository-url>‍‍

use chrome or Firefox developer tools to see what URL is generated for opening the office file - maybe there is something wrong.

kamilaw_
Member II

Re: Edit online still not working

Jump to solution

Thank you very much. The problem is resolved.

And I have one more question.  I had to rewrite this in Alfresco 5.1. and I did not have to do it in Alfresco 5.0.d. There are two possible answers here: 1. It depends in my local settings, then I understand it. 2. It is normal for all Aflresco. Then there should be some article about this. Is there any? It is not very important question, but I try to understand if I went to find the solution correctly.

mehe
Senior Member II

Re: Edit online still not working

Jump to solution

I really can't remember it anymore, but I think I had problems with some document URLs since 5.1 and was missing the "repository-url" (or had the default localhost value) in the share config.  I'm imaginig myself, that repository-url was not necessary before and the urls where built by share.context... in alfresco-global.properties, but can't say for sure...