Error adding users on a site

cancel
Showing results for 
Search instead for 
Did you mean: 
diogosiqueira91
Member II

Error adding users on a site

Hello guys, how are you?

I'm having trouble adding users to the site on Alfresco.

Alfresco version: Alfresco Sharing v5.2.f | Alfresco Community v5.2.0 On the Add users to site tab (Find and select users, assign roles and dominate them for this site.)

Whenever I add a member, the following message appears: 1 user cannot be added

Below is an impression:

Invite.png

Log: / opt / alfresco / tomcat / logs / catalina.out ERROR [extensions.webscripts.AbstractRuntime] [http-apr-8355-exec-13] Execution exception: 01090038 org.alfresco.service.cmr.invitation.InvitationException: 0109131777 Cannot find the email template! - [] An unexpected error occurred during the initial invitation .

The outdoor repository has already been set up and the invite-email.html.ftl file is available and accessible to everyone. (Repository> Data dictionary> Email templates> invitation)

- All Alfresco emails are sent as normal, except guests. (Invitation)

- When I put notification.email.siteinvite as fake in / opt / alfresco / tomcat / shared / classes / alfresco-global.properties,  I get to invite members as usual.

notificação.email.siteinvite = false

Does anyone have any idea what I can do to solve this problem?

I thank everyone.

 

 

8 Replies
sufo
Established Member

Re: Error adding users on a site

Can you doublecheck that user under which you are trying to add members (if it is not an admin) can browse (do it in Share) to Repository->Data Dictionary->Email->invite?
Do you also see Spanish (invite-email_es.html.ftl) version of the template there?
(Just guessing that your Share interface is in Spanish.)

diogosiqueira91
Member II

Re: Error adding users on a site

Hello Sufo, how are you?

The files are in the informed repository.
I'm from Brazil

invite-email.html.ftl, invite-email_pt_BR.html.ft, invite-email_es.html.ftl...and etc.

I am a manager / administrator. Here are my account permissions:

 

permissão.png

sufo
Established Member

Re: Error adding users on a site

Sorry Diogo, don't have any other idea. Maybe one crazy thought. Change your language in browser to English, reload Share and try it again.

cristinamr
Intermediate

Re: Error adding users on a site

Hi!

The error is clear:

Cannot find the email template!

Change the name of invite-email_pt_BR.html.ftl by invite-email_pt.html.ftl and try it again. If not please check if in english is working properly (you need to user english language in your browser). I suspect the problem is pt_BR name.

 

Cheers,

Cris.

--
Check our products: AQuA : https://aqua.venzia.es | Seidoc : https://seidoc.es
diogosiqueira91
Member II

Re: Error adding users on a site

Good idea, but it didn't work.

I also changed the browser language to English, Spanish, etc. It still continues to display the same message.

diogosiqueira91
Member II

Re: Error adding users on a site

Hello, I changed the file to invite-email_pt.html.ftl and still presented the error.

I also changed the browser language to English, Spanish and continued to display the same message.

2021-02-11 19:40:50,013 ERROR [extensions.webscripts.AbstractRuntime] [http-apr-8355-exec-7] Exception from executeScript: 01110091 org.alfresco.service.cmr.invitation.InvitationException: 0111172016 Cannot find the email template! - []Unexpected error occurred during starting invitation
org.springframework.extensions.webscripts.WebScriptException: 01110091 org.alfresco.service.cmr.invitation.InvitationException: 0111172016 Cannot find the email template! - []Unexpected error occurred during starting invitation





EddieMay
Community Manager
Community Manager

Re: Error adding users on a site

Hi @diogosiqueira91 

Could it be a permission issue

Digital Community Manager, Alfresco Software.
Problem solved? Click Accept as Solution!
sufo
Established Member

Re: Error adding users on a site

Hello Diogo, try to create a rule on some temporary folder, choose Send e-mail action and choose to use template there. Then try to upload a document to that folder to see if you receive an e-mail. It is just to see if this works.

Meanwhile, if you can upload your alfresco.log somewhere, I could check if I can see anything else there.