Error on previewing office document in ACS 6.2

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Member II

Error on previewing office document in ACS 6.2

Hello, 

I have installed Alfresco community version 6.2 on a CentOs 7. I'm encoutering an error when I preview office document (docx, xlsx extension)

I have followed these instructions (https://docs.alfresco.com/community/tasks/lo-install.html) : I have installed Libreoffice 6.3 and in alfresco-global.properties I have configured these options : 

jodconverter.officeHome=/opt/libreoffice6.3
jodconverter.portNumbers=8100
jodconverter.enabled=true

But when I click on a thumbbail of an office document, I have an error : "this document cannot be previewed". I've looked at the catalina.out log file and I find only one error but I don't know if it is related : 

2020-10-08 08:30:49,272 ERROR [extensions.webscripts.AbstractRuntime] [http-nio-8080-exec-3] Exception from executeScript: 09080024 Access denied. You do not have the permission to do this operation
org.alfresco.repo.security.permissions.AccessDeniedException: 09080024 Access denied. Vous n'avez pas la permission de réaliser cette opération.
at org.alfresco.repo.security.permissions.impl.ExceptionTranslatorMethodInterceptor.invoke(ExceptionTranslatorMethodInterceptor.java:57)
at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:186)
at org.alfresco.repo.audit.AuditMethodInterceptor.invoke(AuditMethodInterceptor.java:166)
at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:186)
at org.springframework.transaction.interceptor.TransactionAspectSupport.invokeWithinTransaction(TransactionAspectSupport.java:295)
at org.springframework.transaction.interceptor.TransactionInterceptor.invoke(TransactionInterceptor.java:98)
at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:186)
at org.springframework.aop.framework.JdkDynamicAopProxy.invoke(JdkDynamicAopProxy.java:212)
at com.sun.proxy.$Proxy101.setOwner(Unknown Source)

Do you know how to solve my error and make alfresco CS 6.2 preview Office document ?

 

2 Replies
Highlighted
Community Manager
Community Manager

Re: Error on previewing office document in ACS 6.2

Hi @dareal 

At first glance this looks like a permissions issue. Is LibreOffice running, with the correct permissions? Can you call LibreOffice from the cmd line?

HTH,

Digital Community Manager, Alfresco Software.
Problem solved? Click Accept as Solution!
Highlighted
Member II

Re: Error on previewing office document in ACS 6.2

Hello @EddieMay 

Thank you for this link. It seems to have the same error, but it's not the same version of ACS. 

I didn't find libreoffice_ctl.sh or ctl.sh in my alfresco and libreoffice folder. For testing purpose only I have put full rigth on libreoffice folder.

I can launch soffice.bin from cmd line. I can't see libreoffice because it's a non graphic server, but I have no error in the command line (no missing files or modules). 

When I check processes I can see it running : 

root 2025 0.0 0.7 935244 58512 pts/0 Sl 12:45 0:00 /opt/libreoffice6.3/program/soffice.bin -accept=socket,host=127.0.0.1,port=8100;urp; -env:UserInstallation=file:///opt/alfresco/tomcat/temp/.jodconverter_socket_host-127.0.0.1_port-8100 -headless -nocrashreport -nodefault -nofirststartwizard -nolockcheck -nologo -norestore