Error uploading a model

cancel
Showing results for 
Search instead for 
Did you mean: 
user44m
Member II

Error uploading a model

Jump to solution

Hi, 

I am using Docker (with docker-compose up) to start my localhost. At first it seem to work, however when I want to add my own models (from exporting .kickproc file from Eclipse) i get this error message: 

solr6_1 | 2021-01-11 10:28:46.873 ERROR (searcherExecutor-8-thread-1-processing-x:alfresco) [ x:alfresco] o.a.s.t.AbstractTracker Model tracking failed for core: alfresco
solr6_1 | org.alfresco.error.AlfrescoRuntimeException: 00110000 alfresco GetModelsDiff return status is 404
solr6_1 | at org.alfresco.solr.client.SOLRAPIClient.getModelsDiff(SOLRAPIClient.java:1194)
solr6_1 | at org.alfresco.solr.tracker.ModelTracker.trackModelsImpl(ModelTracker.java:291)
solr6_1 | at org.alfresco.solr.tracker.ModelTracker.trackModels(ModelTracker.java:249)
solr6_1 | at org.alfresco.solr.tracker.ModelTracker.ensureFirstModelSync(ModelTracker.java:271)
solr6_1 | at org.alfresco.solr.lifecycle.SolrCoreLoadRegistration.registerForCore(SolrCoreLoadRegistration.java:107)
solr6_1 | at org.alfresco.solr.lifecycle.SolrCoreLoadListener.newSearcher(SolrCoreLoadListener.java:44)
solr6_1 | at org.apache.solr.core.SolrCore.lambda$getSearcher$15(SolrCore.java:2249)
solr6_1 | at java.base/java.util.concurrent.FutureTask.run(FutureTask.java:264)
solr6_1 | at org.apache.solr.common.util.ExecutorUtil$MDCAwareThreadPoolExecutor.lambda$execute$0(ExecutorUtil.java:229)
solr6_1 | at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128)
solr6_1 | at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628)
solr6_1 | at java.base/java.lang.Thread.run(Thread.java:834)

1 Solution

Accepted Solutions
kaynezhang
Advanced

Re: Error uploading a model

Jump to solution

Or you can check your model file maybe the model is invalid.

View solution in original post

2 Replies
EddieMay
Community Manager
Community Manager

Re: Error uploading a model

Jump to solution

Hi @user44m 

Can you please provide the full alfresco logfile output? Also, have a look at this thread.

HTH,

Digital Community Manager, Alfresco Software.
Problem solved? Click Accept as Solution!
kaynezhang
Advanced

Re: Error uploading a model

Jump to solution

Or you can check your model file maybe the model is invalid.

View solution in original post