Error when connecting to Solr

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Member II

Error when connecting to Solr

Hi,

I'm trying to setup an alfresco environment using docker. I'm running the 3 services (alfresco, solr and share) as 3 separate docker containers that communicate with each other through a Load Balancer. They communicate via https with the LB and then the traffic gets forwarded to the containers using http. Share to Alfresco communications seems to be working correctly as I'm able to login to share. The issue is with solr and alfresco communication, I'm seeing a tracking error in solr console like this: 

GetModelsDiff return status is 400


I'm wondering if we need to set SSL between alfresco and solr if the load balancer is only exposing port 443 via https. Or is this a non-related issue? I guess my question would be, is there any way I can use https addresses to communicate between solr and alfresco but not configuring solr to use SSL? Thanks a lot! first time posting, let me know if I should post this in another forum Smiley Happy 

Edit:
More details on my setup:
Solr is exposing port 8983 via http
Alfresco is exposing port 8080 via http
Share is exposing port 8081 via http
The load balancer is listening on port 443 via https and forwarding calls to their respective containers (For example '/share' requests to share) via http

For Solr I have the following env variables (values in brackets are not the actual values)

SOLR_ALFRESCO_HOST={url-to-alfresco}
SOLR_ALFRESCO_PORT=443
SOLR_SOLR_HOST={url-to-solr}
SOLR_SOLR_PORT=443
SOLR_CREATE_ALFRESCO_DEFAULTS=alfresco,archive

For Alfresco I have the following env variables (values in brackets are not the actual values)

JAVA_OPTS='-Ddb.driver=com.mysql.jdbc.Driver -Ddb.username={username} -Ddb.password={password} -Ddb.url="{db-url}" -Dsolr.host={url-to-solr} -Dsolr.port=443 -Dsolr.secureComms=none -Dsolr.base.url=/solr -Dindex.subsystem.name=solr6'