Error while running alfresco sdk 4 on local machine

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Established Member II

Error while running alfresco sdk 4 on local machine

Hi all,

I had set up an intelliJ alfresco sdk 4.0 enterprise project on local machine(eindows 64) and it used to run earlier with earlier versions like alfresco.platform.version as 6.1.0.2 and alfresco.share.version as 6.1.0.

With below configuration in ~proj/pom.xml and using the alfresco 6.1 license .

<!-- Properties used in dependency declarations, you don't need to change these -->
<alfresco.groupId>org.alfresco</alfresco.groupId>
<alfresco.bomDependencyArtifactId>acs-packaging</alfresco.bomDependencyArtifactId>
<alfresco.platform.version>6.1.0.2</alfresco.platform.version>
<alfresco.share.version>6.1.0</alfresco.share.version>

<!-- Docker images -->
<docker.acs.image>alfresco/alfresco-content-repository</docker.acs.image>
<docker.share.image>alfresco/alfresco-share</docker.share.image>

But , I just 2 days back started the project with command -

C:\github\acs> run.bat build_start 

Get the below error:

 

2019-10-27 12:41:40.049 ERROR (org.alfresco.solr.AlfrescoCoreAdminHandler@59d4cd39_Worker-1) [ ] o.a.s.t.AbstractTracker Tracking failed for ModelTracker - alfresco
aio-ass_1 | org.alfresco.error.AlfrescoRuntimeException: 09270001 alfresco GetModelsDiff return status is 404
aio-ass_1 | at org.alfresco.solr.client.SOLRAPIClient.getModelsDiff(SOLRAPIClient.java:1181)aio-ass_1 | at org.alfresco.solr.tracker.ModelTracker.trackModelsImpl(ModelTracker.java:291)
aio-ass_1 | at org.alfresco.solr.tracker.ModelTracker.trackModels(ModelTracker.java:249)
aio-ass_1 | at org.alfresco.solr.tracker.ModelTracker.doTrack(ModelTracker.java:209)
aio-ass_1 | at org.alfresco.solr.tracker.AbstractTracker.track(AbstractTracker.java:215)
aio-ass_1 | at org.alfresco.solr.tracker.TrackerJob.execute(TrackerJob.java:47)
aio-ass_1 | at org.quartz.core.JobRunShell.run(JobRunShell.java:216)
aio-ass_1 | at org.quartz.simpl.SimpleThreadPool$WorkerThread.run(SimpleThreadPool.java:563)

 

Can anyone suggest if he faced this issue and any possible fix.

 

1 Reply
Highlighted
Established Member II

Re: Error while running alfresco sdk 4 on local machine

Hi all,

 

Was able to get past this issue .

 

Just did run.bat purge -> to remove the existing solr data nd reindexed . Now up and working