Failed to get access to Alfresco 7.0.0 in CMIS with ObjectiveCMIS

Showing results for 
Search instead for 
Did you mean: 

Failed to get access to Alfresco 7.0.0 in CMIS with ObjectiveCMIS


We've developped a mobile app relying on a Alfresco 4.2 Community. The link is done using CMIS and especially ObjectiveCMIS lib. Today, we're upgrading our Alfresco server to 7.0.0 COmmunity and are facing some problems communicating in CMIS with this new server from our mobile app.
With Alfresco 4.2, the mobile app was pointing to /alfresco/cmisatom.
Now, we're pointing to /alfresco/api/-default-/public/cmis/versions/1.0/atom and it leads to the following error:
Error initializing connection : Error Domain=org.apache.chemistry.objectivecmis Code=3 "Unauthorized Access" UserInfo={NSLocalizedDescription=Unauthorized Access, NSLocalizedFailureReason=07250012 Authentication failed for Web Script org/alfresco/api/opencmis/OpenCMIS.get}

I've tried to add the alf_ticket parameter (generated with a call to /alfresco/api/login) to the URL to fix the problem but it leads to another error:
Error Domain=org.apache.chemistry.objectivecmis Code=258 "Not Supported Error" UserInfo={NSLocalizedDescription=Not Supported Error, NSLocalizedFailureReason=Base type '0' not supported.

As far as my Alfresco configuration is concerned, I have the following CMIS parameters in


I've also tried to connect to this server with CMIS Workbench (1.1.0) using the following URL and it works:
Saying that, I think that my server configuration is good.

My Alfresco server is behind an Apache httpd rpoxy configured as followed:

<VirtualHost *:80>
ServerName [...]
ServerAlias [...]

RewriteEngine On
ProxyRequests Off
RewriteRule ^/$ /share [R=302,L]

<Proxy *>
Order deny,allow
Allow from all

ProxyPass /
ProxyPassReverse /

<Location />
Order allow,deny
Allow from all


We've upgraded ObjectiveCMIS lib (from 0.2 to 0.6) => still KO
I've also added the following parameter to => still KO too:


Is there something particular to do with ObjectiveCMIS lib to get access to an Alfresco 7.0.0 server?
Is there something to do about Apache configuration?
What can I do to debug that on the mobile app side?
Are there some logs to enable on the server side to help debugging?