First Alfresco project in Eclipse

Showing results for 
Search instead for 
Did you mean: 
Member II

First Alfresco project in Eclipse

Hi! I've started in my first project in Alfresco project in Eclipse. I tried to use alfresco-allinone-archetype version 3.0.1. But during generating project I've got an error 

"Could not get the value for parameter encoding for plugin execution default-resources.

Plugin org.apache.maven.plugins:maven-resources-plugin:3.0.1 or one of its dependencies could not be resolved: Failure to transfer commons-io:commons-io:jar:2.4 from was cached in the local repository, resolution will not be reattempted until the update interval of central has elapsed or updates are forced. Original error: Could not transfer artifact commons-io:commons-io:jar:2.4 from/to central ( The operation was cancelled". I use maven-3.5.0 and spring-tool-suite-3.9.0.RELEASE-e4.7.0-win32-x86_64. Does anybody know what is the problem?

1 Reply
Advanced II

Re: First Alfresco project in Eclipse


Have you tried to execute Maven using the command line?

Maybe Eclipse is using the embeded version, that at least in the past, was always an older version.