getting started wtih docker

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Active Member

getting started wtih docker

hi guys, new to Alfresco and i'm excited about getting it up and running.

i'm having a problem with the community eddition though, 

i have basically followed;

https://www.alfresco.com/thank-you/thank-you-downloading-alfresco-community-edition 

installed docker, downloaded the YML file and ran the "alfresco-compose up" command on my windows 10 machine

there was plenty going on in powershell but it appears to stall / hang.

powershell is showing

 

  : --------------------------------------------------------------------------------------------------------------------------------------------------------------
transform-misc_1         | 2020-04-17 08:56:53.391  INFO 1 --- [           main] org.alfresco.transformer.Application     : Starting application components... Done
alfresco-pdf-renderer_1  | 2020-04-17 09:07:50.752  INFO 1 --- [nio-8090-exec-1] o.a.c.c.C.[Tomcat].[localhost].[/]       : Initializing Spring DispatcherServlet 'dispatcherServlet'
alfresco-pdf-renderer_1  | 2020-04-17 09:07:51.603  INFO 1 --- [nio-8090-exec-1] o.s.web.servlet.DispatcherServlet        : Initializing Servlet 'dispatcherServlet'
alfresco-pdf-renderer_1  | 2020-04-17 09:07:56.760  INFO 1 --- [nio-8090-exec-1] o.s.web.servlet.DispatcherServlet        : Completed initialization in 5081 ms
alfresco-pdf-renderer_1  | 2020-04-17 09:09:49.252  INFO 1 --- [nio-8090-exec-1] o.a.t.AbstractTransformerController      : GET Transform Config.
alfresco-pdf-renderer_1  | 2020-04-17 09:09:49.251  INFO 1 --- [nio-8090-exec-2] o.a.t.AbstractTransformerController      : GET Transform Config.
proxy_1                  | 172.18.0.1 - - [17/Apr/2020:09:29:01 +0000] "GET /alfresco HTTP/1.1" 301 169 "-" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/80.0.3987.163 Safari/537.36"
proxy_1                  | 2020/04/17 09:30:40 [error] 7#7: *1 upstream timed out (110: Operation timed out) while reading response header from upstream, client: 172.18.0.1, server: , request: "GET /alfresco/ HTTP/1.1", upstream: "http://172.18.0.8:8080/alfresco/", host: "localhost:8080"
proxy_1                  | 172.18.0.1 - - [17/Apr/2020:09:30:40 +0000] "GET /alfresco/ HTTP/1.1" 504 569 "-" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/80.0.3987.163 Safari/537.36"
proxy_1                  | 2020/04/17 09:31:44 [error] 7#7: *1 upstream timed out (110: Operation timed out) while reading response header from upstream, client: 172.18.0.1, server: , request: "GET /favicon.ico HTTP/1.1", upstream: "http://172.18.0.8:8080/favicon.ico", host: "localhost:8080", referrer: "http://localhost:8080/alfresco/"
proxy_1                  | 172.18.0.1 - - [17/Apr/2020:09:31:44 +0000] "GET /favicon.ico HTTP/1.1" 504 569 "http://localhost:8080/alfresco/" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/80.0.3987.163 Safari/537.36"

i tried navigating to http://localhost:8080/alfresco/ and i'm getting a 504 Gateway Time-out

any thoughts?

 

7 Replies
Highlighted
Established Member

Re: getting started wtih docker

Have you got any solution same issue  i am also facing.

 

Thanks in Advance

Highlighted
Active Member

Re: getting started wtih docker

Yes I did actually, check your docker settings and increase the CPU cores and ram

 

Bump th ram up to a minimum of 7gig and then try it again

 

It should al work from there

Highlighted
Established Member

Re: getting started wtih docker

So i should uninstall docker and again install it and change the configuration and then run the docker-compose up again??

Or i should change the setting at this time only.

Please suggest.

 

Thanks in Advance

Akash 

Highlighted
Community Manager
Community Manager

Re: getting started wtih docker

Hi @akash251998,

You should be OK to just increase the RAM to at least 8GB, then restart docker & then run docker-compose up.

HTH,

Digital Community Manager, Alfresco Software.
Problem solved? Click Accept as Solution!
Highlighted
Established Member

Re: getting started wtih docker

My system configuration is 8 gb RAM only.

20200714_162525.jpg

 

@EddieMay This is my system configuration but Docker maximum memory is 3.75 what configuration i should make so that i can do the installation. I feel i am asking a lot. Any help will be appreciable.

Highlighted
Community Manager
Community Manager

Re: getting started wtih docker

Hi @akash251998,

I'm afraid you won't be able to run Alfresco ACS on your machine - 8GB ram is the minimum (I assign 12GB ram on my laptop).  I suggest you try the online trial version while you look at upgrading your machine.

Cheers,

Digital Community Manager, Alfresco Software.
Problem solved? Click Accept as Solution!
Highlighted
Established Member

Re: getting started wtih docker

Thanku so much dear @EddieMay i will upgrade and again do the installation.