HELP with ACS, Ansible, and obtaining the necessary NEXUS_USERNAME & PASSWORD to install it?

cancel
Showing results for 
Search instead for 
Did you mean: 
michaelzietlow
Active Member II

HELP with ACS, Ansible, and obtaining the necessary NEXUS_USERNAME & PASSWORD to install it?

Jump to solution

I'm investigating if an upgrade of my Community 5.2 build to Community 7.0 is possible (easy?).

I want to try and install it locally on my Centos/7 machine.

I read that Alfresco Community Edition 7.0 is available as a distribution zip file for manual installation, or it can be installed using an Ansible playbook (Linux only) for non-containerized environments.

I downloaded the Ansible zip but the procedure necessary to obtain a NEXUS_USERNAME/PASSWORD so I can run the ansible play but the instructions do not detail how to obtain a login/password.

Any Help/Guidance on getting the needed credentials to install Community7 via ansible would be appreciated.

1 Solution

Accepted Solutions
abhinavmishra14
Advanced

Re: HELP with ACS, Ansible, and obtaining the necessary NEXUS_USERNAME & PASSWORD to install it?

Jump to solution

Seems like you are using enterprise version package of ansible to install community if i am not wrong. Check your xx-extra-vars.yml to make sure edition value is community and all the dowload urls are pointing to community repo.

Trying downloading the ansible package from here:  https://download.alfresco.com/cloudfront/release/community/alfresco-ansible-deployment/alfresco-ansi...

For more detailed info refer: 

https://docs.alfresco.com/content-services/community/install/ansible/

Notice in documentation for enterprise command is: 

ansible-playbook playbooks/acs.yml -i inventory_local.yml

 For community version command is: 

ansible-playbook playbooks/acs.yml -i inventory_local.yml -e "@community-extra-vars.yml"

 

~Abhinav
(ACSCE, AWS SAA-C02, GAIQ)

View solution in original post

6 Replies
cristinamr
Advanced

Re: HELP with ACS, Ansible, and obtaining the necessary NEXUS_USERNAME & PASSWORD to install it?

Jump to solution

Hi! I've never used ansible but searching on Alfresco docs I've found this post (maybe it can helps you?).

In a point of view of perform a migration from Alfresco 5.2 to 7, it's possible. You can check here how is the process. If it's your first time: i'll suggest you first do it with Alfresco 5.2 vanilla in your local machine, just to practice the process. Document the process. Then, make a backup of Alfresco 5.2 and try in your local again. And at the end, try in your servers.

Cheers,

Cristina.

--
VenziaIT: helping companies since 2005! Our ECM products: AQuA & Seidoc
michaelzietlow
Active Member II

Re: HELP with ACS, Ansible, and obtaining the necessary NEXUS_USERNAME & PASSWORD to install it?

Jump to solution

Thanks cristinamr,

 

Yes I read that.  It assumes you have ACS7 installed so you can then modify the *.properties files.

The issue is the ansible install requires NEXUS login Credentials in order to download alfresco-content-services-distribution-7.0.0.zip


The Link Ansible is trying to download from is :
https://artifacts.alfresco.com/nexus/service/local/repositories/enterprise-releases/content/org/alfr...

It's extremly frustrating when an install document tells me to enter a nexus username & password but does not tell you how to request one.

 

TASK [../roles/transformers : Remove from content services] *************************************************************************************************************************
ok: [transformers_1]

TASK [../roles/transformers : Download alfresco-transform-core-aio-boot-2.3.10.jar] *************************************************************************************************
fatal: [transformers_1]: FAILED! => {"msg": "An unhandled exception occurred while templating '{u'acs_zip_sha1_checksum': u\"{{ lookup('url', '{{ nexus_repository.enterprise_releases }}org/alfresco/alfresco-content-services-distribution/{{ acs.version }}/alfresco-content-services-distribution-{{ acs.version }}.zip.sha1', username=lookup('env', 'NEXUS_USERNAME'), password=lookup('env', 'NEXUS_PASSWORD')) }}\", u'adw_zip_sha1_checksum': u\"{{ lookup('url', '{{ nexus_repository.enterprise_releases }}/org/alfresco/alfresco-digital-workspace/{{ adw.version }}/alfresco-digital-workspace-{{ adw.version }}.zip.sha1', username=lookup('env', 'NEXUS_USERNAME'), password=lookup('env', 'NEXUS_PASSWORD')) }}\", u'acs_zip_url': u'{{ nexus_repository.enterprise_releases }}org/alfresco/alfresco-content-services-distribution/{{ acs.version }}/alfresco-content-services-distribution-{{ acs.version }}.zip', u'transform_jar_sha1_checksum': u\"{{ lookup('url', '{{ nexus_repository.releases }}/org/alfresco/alfresco-transform-core-aio-boot/{{ transform.version }}/alfresco-transform-core-aio-boot-{{ transform.version }}.jar.sha1', username=lookup('env', 'NEXUS_USERNAME'), password=lookup('env', 'NEXUS_PASSWORD')) }}\", u'trouter_jar_url': u'{{ nexus_repository.enterprise_releases }}/org/alfresco/alfresco-transform-router/{{ trouter.version }}/alfresco-transform-router-{{ trouter.version }}.jar', u'search_zip_url': u'{{ nexus_repository.releases }}/org/alfresco/alfresco-search-services/{{ search.version }}/alfresco-search-services-{{ search.version }}.zip', u'sfs_jar_url': u'{{ nexus_repository.enterprise_releases }}/org/alfresco/alfresco-shared-file-store-controller/{{ sfs.version }}/alfresco-shared-file-store-controller-{{ sfs.version }}.jar', u'search_zip_sha1_checksum': u\"{{ lookup('url', '{{ nexus_repository.releases }}/org/alfresco/alfresco-search-services/{{ search.version }}/alfresco-search-services-{{ search.version }}.zip.sha1', username=lookup('env', 'NEXUS_USERNAME'), password=lookup('env', 'NEXUS_PASSWORD')) }}\", u'sync_zip_url': u'https://artifacts.alfresco.com/nexus/content/groups/private/org/alfresco/services/sync/sync-dist-6.x/{{ sync.version }}/sync-dist-6.x-{{ sync.version }}.zip', u'trouter_jar_sha1_checksum': u\"{{ lookup('url', '{{ nexus_repository.enterprise_releases }}/org/alfresco/alfresco-transform-router/{{ trouter.version }}/alfresco-transform-router-{{ trouter.version }}.jar.sha1', username=lookup('env', 'NEXUS_USERNAME'), password=lookup('env', 'NEXUS_PASSWORD')) }}\", u'sfs_jar_sha1_checksum': u\"{{ lookup('url', '{{ nexus_repository.enterprise_releases }}/org/alfresco/alfresco-shared-file-store-controller/{{ sfs.version }}/alfresco-shared-file-store-controller-{{ sfs.version }}.jar.sha1', username=lookup('env', 'NEXUS_USERNAME'), password=lookup('env', 'NEXUS_PASSWORD')) }}\", u'sync_zip_sha1_checksum': u\"{{ lookup('url', 'https://artifacts.alfresco.com/nexus/content/groups/private/org/alfresco/services/sync/sync-dist-6.x/{{ sync.version }}/sync-dist-6.x-{{ sync.version }}.zip.sha1', username=lookup('env', 'NEXUS_USERNAME'), password=lookup('env', 'NEXUS_PASSWORD')) }}\", u'transform_jar_url': u'{{ nexus_repository.releases }}/org/alfresco/alfresco-transform-core-aio-boot/{{ transform.version }}/alfresco-transform-core-aio-boot-{{ transform.version }}.jar', u'adw_zip_url': u'{{ nexus_repository.enterprise_releases }}/org/alfresco/alfresco-digital-workspace/{{ adw.version }}/alfresco-digital-workspace-{{ adw.version }}.zip'}'. Error was a <class 'ansible.errors.AnsibleError'>, original message: An unhandled exception occurred while running the lookup plugin 'url'. Error was a <class 'ansible.errors.AnsibleError'>, original message: Received HTTP error for https://artifacts.alfresco.com/nexus/service/local/repositories/enterprise-releases/content/org/alfresco/alfresco-content-services-distribution/7.0.0/alfresco-content-services-distribution-7.0.0.zip.sha1 : HTTP Error 401: Unauthorized"}

PLAY RECAP **************************************************************************************************************************************************************************
activemq_1                 : ok=23   changed=3    unreachable=0    failed=0    skipped=9    rescued=0    ignored=0   
database_1                 : ok=19   changed=3    unreachable=0    failed=0    skipped=3    rescued=0    ignored=0   
transformers_1             : ok=19   changed=0    unreachable=0    failed=1    skipped=15   rescued=0    ignored=0   

 

abhinavmishra14
Advanced

Re: HELP with ACS, Ansible, and obtaining the necessary NEXUS_USERNAME & PASSWORD to install it?

Jump to solution

Seems like you are using enterprise version package of ansible to install community if i am not wrong. Check your xx-extra-vars.yml to make sure edition value is community and all the dowload urls are pointing to community repo.

Trying downloading the ansible package from here:  https://download.alfresco.com/cloudfront/release/community/alfresco-ansible-deployment/alfresco-ansi...

For more detailed info refer: 

https://docs.alfresco.com/content-services/community/install/ansible/

Notice in documentation for enterprise command is: 

ansible-playbook playbooks/acs.yml -i inventory_local.yml

 For community version command is: 

ansible-playbook playbooks/acs.yml -i inventory_local.yml -e "@community-extra-vars.yml"

 

~Abhinav
(ACSCE, AWS SAA-C02, GAIQ)

View solution in original post

michaelzietlow
Active Member II

Re: HELP with ACS, Ansible, and obtaining the necessary NEXUS_USERNAME & PASSWORD to install it?

Jump to solution

Thanks, that helps!   Migrating from 5.x to 7 seams to be pretty difficult.
I mis the days of just copying over my alf_data dir...

 

PS. We're trying to get a Quote for the Enterprise edition + Support but I guess everyone is pretty busy at Alfresco...

abhinavmishra14
Advanced

Re: HELP with ACS, Ansible, and obtaining the necessary NEXUS_USERNAME & PASSWORD to install it?

Jump to solution

Glad to hear that, good luck. 

~Abhinav
(ACSCE, AWS SAA-C02, GAIQ)
EddieMay
Community Manager
Community Manager

Re: HELP with ACS, Ansible, and obtaining the necessary NEXUS_USERNAME & PASSWORD to install it?

Jump to solution

Hi @michaelzietlow 

Thank you for accepting the solution - helpful to other users.

Cheers,

Digital Community Manager, Alfresco Software.
Problem solved? Click Accept as Solution!