How to mount a CompanyHome/folder/subfolder with IMAP ?

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Active Member II

How to mount a CompanyHome/folder/subfolder with IMAP ?

Hello

After installing alfresco there will be a default folder structure under repository. Now lets add a testfolder & a subfolderX. Question is, how to mount subfolderX ?

Company Home/
                         User Homes
                         Sites
                         Shared
                         IMAP Home                      

                         testfolder/

                                           subfolderX

 Example working code to mount testfolder:

imap.server.enabled=true
imap.server.port=143
imap.config.server.mountPoints=AlfrescoIMAP
imap.config.server.mountPoints.value.AlfrescoIMAP.mountPointName=Alfresco IMAPx
imap.config.server.mountPoints.value.AlfrescoIMAP.modeName=ARCHIVE
imap.config.server.mountPoints.value.AlfrescoIMAP.rootPath=/app:company_home/cm:testfolder

But How to mount that subfolderX ?

...mountPoints.value.AlfrescoIMAP.rootPath=/app:company_home/cm:testfolder/cm:subfolderX ???
2 Replies
Highlighted
Established Member

Re: How to mount a CompanyHome/folder/subfolder with IMAP ?

Hi 

Check out following imap default properties


# Default IMAP mount points

imap.config.home.store=${spaces.store}

imap.config.home.rootPath=/${spaces.company_home.childname} i

map.config.home.folderPath=${spaces.imap_home.childname}

imap.config.server.mountPoints=AlfrescoIMAP

imap.config.server.mountPoints.default.mountPointName=IMAP

imap.config.server.mountPoints.default.modeName=ARCHIVE

imap.config.server.mountPoints.default.store=${spaces.store}

imap.config.server.mountPoints.default.rootPath=${protocols.rootPath}

imap.config.server.mountPoints.value.AlfrescoIMAP.mountPointName=Alfresco IMAP

imap.config.server.mountPoints.value.AlfrescoIMAP.modeName=MIXED


Highlighted
Active Member II

Re: How to mount a CompanyHome/folder/subfolder with IMAP ?

Looks like this solved the issue:, topic can be closed, thank you.

### IMAP working configuration ###
imap.server.enabled=true
imap.server.port=143
imap.config.server.mountPoints=AlfrescoIMAP
imap.config.server.mountPoints.value.AlfrescoIMAP.mountPointName=Alfresco IMAPxy
imap.config.server.mountPoints.value.AlfrescoIMAP.modeName=ARCHIVE
imap.config.server.mountPoints.value.AlfrescoIMAP.folderPath=cm:testfolder/cm:subfolderX
imap.config.server.mountPoints.AlfrescoIMAP.modeName=MIXED