How to solve GetTextContentResponse errors at Alfresco 5 application?

cancel
Showing results for 
Search instead for 
Did you mean: 
wuarmin
Active Member II

How to solve GetTextContentResponse errors at Alfresco 5 application?

I have a problem with my Alfresco 5.0 application. My log files contain tons of following errors:

catalina.out

2020-12-09 16:28:23,622  ERROR [extensions.webscripts.AbstractRuntime] [http-bio-8443-exec-5] Exception from executeScript - redirecting to status template error: Server error (110912403).  Details can be found in the server logs.
 java.lang.RuntimeException: Server error (110912403).  Details can be found in the server logs.
	at org.alfresco.repo.web.scripts.RepositoryContainer.executeScript(RepositoryContainer.java:299)
	at org.springframework.extensions.webscripts.AbstractRuntime.executeScript(AbstractRuntime.java:378)
	at org.springframework.extensions.webscripts.AbstractRuntime.executeScript(AbstractRuntime.java:209)
	at org.springframework.extensions.webscripts.servlet.WebScriptServlet.service(WebScriptServlet.java:132)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:727)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:303)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:208)
	at org.apache.tomcat.websocket.server.WsFilter.doFilter(WsFilter.java:52)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:241)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:208)
	at org.alfresco.web.app.servlet.GlobalLocalizationFilter.doFilter(GlobalLocalizationFilter.java:61)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:241)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:208)
	at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:220)
	at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:122)
	at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:613)
	at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:170)
	at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:103)
	at org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:950)
	at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:116)
	at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:421)
	at org.apache.coyote.http11.AbstractHttp11Processor.process(AbstractHttp11Processor.java:1074)
	at org.apache.coyote.AbstractProtocol$AbstractConnectionHandler.process(AbstractProtocol.java:611)
	at org.apache.tomcat.util.net.JIoEndpoint$SocketProcessor.run(JIoEndpoint.java:314)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
	at org.apache.tomcat.util.threads.TaskThread$WrappingRunnable.run(TaskThread.java:61)
	at java.lang.Thread.run(Thread.java:745)
org.alfresco.error.AlfrescoRuntimeException: 110910909 GetTextContentResponse return status is 500
	at org.alfresco.solr.client.SOLRAPIClient.getTextContent(SOLRAPIClient.java:1028)
	at org.alfresco.solr.SolrInformationServer.addContentPropertyToDocUsingAlfrescoRepository(SolrInformationServer.java:2451)
	at org.alfresco.solr.SolrInformationServer.addContentToDoc(SolrInformationServer.java:2438)
	at org.alfresco.solr.SolrInformationServer.updateContentToIndexAndCache(SolrInformationServer.java:2372)
	at org.alfresco.solr.tracker.ContentTracker$ContentIndexWorkerRunnable.doWork(ContentTracker.java:133)
	at org.alfresco.solr.tracker.AbstractWorkerRunnable.run(AbstractWorkerRunnable.java:40)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
	at java.lang.Thread.run(Thread.java:745)

alfresco.log

2020-12-09 16:28:23,622 ERROR [org.springframework.extensions.webscripts.AbstractRuntime] [http-bio-8443-exec-26] Exception from executeScript - redirecting to status template error: Server error (110912706).  Details can be found in the server logs.
java.lang.RuntimeException: Server error (110912706).  Details can be found in the server logs.
	at org.alfresco.repo.web.scripts.RepositoryContainer.executeScript(RepositoryContainer.java:299)
	at org.springframework.extensions.webscripts.AbstractRuntime.executeScript(AbstractRuntime.java:378)
	at org.springframework.extensions.webscripts.AbstractRuntime.executeScript(AbstractRuntime.java:209)
	at org.springframework.extensions.webscripts.servlet.WebScriptServlet.service(WebScriptServlet.java:132)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:727)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:303)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:208)
	at org.apache.tomcat.websocket.server.WsFilter.doFilter(WsFilter.java:52)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:241)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:208)
	at org.alfresco.web.app.servlet.GlobalLocalizationFilter.doFilter(GlobalLocalizationFilter.java:61)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:241)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:208)
	at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:220)
	at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:122)
	at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:613)
	at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:170)
	at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:103)
	at org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:950)
	at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:116)
	at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:421)
	at org.apache.coyote.http11.AbstractHttp11Processor.process(AbstractHttp11Processor.java:1074)
	at org.apache.coyote.AbstractProtocol$AbstractConnectionHandler.process(AbstractProtocol.java:611)
	at org.apache.tomcat.util.net.JIoEndpoint$SocketProcessor.run(JIoEndpoint.java:314)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
	at org.apache.tomcat.util.threads.TaskThread$WrappingRunnable.run(TaskThread.java:61)
	at java.lang.Thread.run(Thread.java:745)

I think they belong together, but I could not find a reason until now.
The solr4 Dashboard looks good (i.e. enough memory available).
If I navigate through the app, there are no errors visible, but sometimes the app becomes very very slow.
Maybe some of you can help me and point me in the right direction.

Thanks and best regards!

5 Replies
angelborroy
Alfresco Employee

Re: How to solve GetTextContentResponse errors at Alfresco 5 application?

That problem is related with the transformation of documents to text. Is your LibreOffice server working fine?

Hyland Developer Evangelist
wuarmin
Active Member II

Re: How to solve GetTextContentResponse errors at Alfresco 5 application?

Thank you @angelborroy  for your response. I checked my LibreOffice installation (I checked if all libs (debian) are installed). Furthermore I restarted LibreOffice:

alf@alfserver:/srv/alfresco# libreoffice/scripts/libreoffice_ctl.sh status
libreoffice not running
alf@alfserver:/srv/alfresco# libreoffice/scripts/libreoffice_ctl.sh start
libreoffice/scripts/libreoffice_ctl.sh : libreoffice started at port 8100
alf@alfserver:/srv/alfresco# libreoffice/scripts/libreoffice_ctl.sh status
libreoffice already running
alf@alfserver:/srv/alfresco# libreoffice/scripts/libreoffice_ctl.sh status
libreoffice already running

Here are the Alfresco properties:

### External executable locations ###
ooo.exe=/srv/alfresco/libreoffice/program/soffice
ooo.enabled=true
ooo.port=8100
img.root=/srv/alfresco/common
img.dyn=${img.root}/lib
img.exe=${img.root}/bin/convert
swf.exe=/srv/alfresco/common/bin/pdf2swf
swf.languagedir=/srv/alfresco/common/japanese

jodconverter.enabled=false
jodconverter.officeHome=/srv/alfresco/libreoffice
jodconverter.portNumbers=8100

Unfortunately the errors are still in the logs.

EddieMay
Community Manager
Community Manager

Re: How to solve GetTextContentResponse errors at Alfresco 5 application?

Hi @wuarmin 

Have you had a look at this post? Might be worth investigating if this is a similar issue.

HTH,

Digital Community Manager, Alfresco Software.
Problem solved? Click Accept as Solution!
wuarmin
Active Member II

Re: How to solve GetTextContentResponse errors at Alfresco 5 application?

Hi @EddieMay ,

thank you for your response. I tripped over that Question a couple of times. I checked my Solr4 summary and it looked ok (apart from the unindexed node-count of 613683), and so I came to the conclusion, that it's another issue. Do you think reindexing could help?

Here's the Solr4 Report

<?xml version="1.0" encoding="UTF-8"?>
<response>
   <lst name="responseHeader">
      <int name="status">0</int>
      <int name="QTime">4554</int>
   </lst>
   <lst name="Summary">
      <lst name="alfresco">
         <long name="Alfresco Acls in Index">1376029</long>
         <long name="Alfresco Nodes in Index">2608249</long>
         <long name="Alfresco Transactions in Index">3114972</long>
         <long name="Alfresco Acl Transactions in Index">748486</long>
         <long name="Alfresco States in Index">2</long>
         <long name="Alfresco Unindexed Nodes">613683</long>
         <long name="Alfresco Error Nodes in Index">1</long>
        
...
</response>

Thank you for your help.

wuarmin
Active Member II

Re: How to solve GetTextContentResponse errors at Alfresco 5 application?

The error, I reported in previous messages, dissappeared. I can only guess why. I guess Solr tries to reindex the unindexed nodes, after application start. Could that be an explanation??

The unindexed node-amount is still the same (613683). Here's another query-response (https://localhost:8443/solr4/alfresco/afts?q=DOC_TYPE:UnindexedNode):

<response>
<lst name="responseHeader">
<int name="status">0</int>
<int name="QTime">1</int>
</lst>
<str name="_original_parameters_">
org.apache.solr.common.params.DefaultSolrParams:{params(q=DOC_TYPE:UnindexedNode),defaults(spellcheck.collateExtendedResults=true&defType=afts&spellcheck.maxResultsForSuggest=5&spellcheck=false&spellcheck.maxCollations=3&spellcheck.count=5&spellcheck.maxCollationTries=5&spellcheck.alternativeTermCount=2&spellcheck.extendedResults=false&spellcheck.collate=true)}
</str>
<lst name="_field_mappings_"/>
<lst name="_date_mappings_"/>
<lst name="_range_mappings_"/>
<lst name="_pivot_mappings_"/>
<lst name="_interval_mappings_"/>
<lst name="_stats_field_mappings_"/>
<lst name="_stats_facet_mappings_"/>
<result name="response" numFound="613689" start="0">
<doc>
<str name="id">_DEFAULT_!80000000000005f2!80000000001f361c</str>
<long name="_version_">0</long>
<long name="DBID">2045468</long>
</doc>
<doc>
<str name="id">_DEFAULT_!800000000007b6ac!80000000001f3480</str>
<long name="_version_">0</long>
<long name="DBID">2045056</long>
</doc>
<doc>
<str name="id">_DEFAULT_!800000000007b6b0!80000000001f347e</str>
<long name="_version_">0</long>
<long name="DBID">2045054</long>
</doc>
<doc>
<str name="id">_DEFAULT_!80000000000029ce!80000000001f3608</str>
<long name="_version_">0</long>
<long name="DBID">2045448</long>
</doc>
<doc>
<str name="id">_DEFAULT_!80000000000029ce!80000000001f3605</str>
<long name="_version_">0</long>
<long name="DBID">2045445</long>
</doc>
<doc>
<str name="id">_DEFAULT_!8000000000003286!80000000001f2eed</str>
<long name="_version_">0</long>
<long name="DBID">2043629</long>
</doc>
<doc>
<str name="id">_DEFAULT_!800000000007ab6e!80000000001f0f8e</str>
<long name="_version_">0</long>
<long name="DBID">2035598</long>
</doc>
<doc>
<str name="id">_DEFAULT_!800000000007ab72!80000000001f08db</str>
<long name="_version_">0</long>
<long name="DBID">2033883</long>
</doc>
<doc>
<str name="id">_DEFAULT_!800000000007ac3c!80000000001f1c4f</str>
<long name="_version_">0</long>
<long name="DBID">2038863</long>
</doc>
<doc>
<str name="id">_DEFAULT_!800000000007b118!80000000001f22c8</str>
<long name="_version_">0</long>
<long name="DBID">2040520</long>
</doc>
</result>
<bool name="processedDenies">false</bool>
</response>

Should I try to reindex?

Furthermore I have the issue, that text/plain documents (filesize does not matter) cannot be previewed. There's no error in any log-file. Do you have an idea?

Thx